Flashed code, got errors and Electron now in DFU mode

I tried to flash my code but it left my electron blinking main LED yellow at around 250ms, blinking the second (red) LED at 500ms, and leaving the third (blue) D7 LED on. The terminal looks like this:

Try particle update -v to resurrect your device.

BTW, is this an independent issue from the other thread you opened?
If not - don’t create multiple threads for related issues and if the solution in the other thread also reandered this one void please close this topic off too.

1 Like

Thanks for your help @ScruffR. My previous thread was asking how to flash code OTA. Meanwhile, I tried plugging the electron in to flash via USB cable and I got the screenshot you see above. I don’t know if this is an independent issue. I figured it was, because my previous thread was that the workbench wasn’t finding my device, and this one was that it’s finding my device (now that it was plugged in) but throwing some sort of error. Maybe it depends how you look at it.

Here’s what my screen shows after trying particle update -v


Does Windows Device Manager show the device connected?
Under which category?
Have you checked with different USB cables?
Can you share a video (>30 sec) of the blink pattern?