[FIXED] Particle Core Doesn't Appear in Device Manager - Windows 7


I have a Particle Core that I successfully configured in September via command line on my Windows 7 laptop (Thinkpad x1 Carbon).

I just powered it up again and it wasn’t connecting, so did a factory reset (hold down both buttons then release the right one). I tried configuring it with the legacy iPhone app, but it kept timing out without luck so I tried the CLI interface. I’ve tried both USB ports (USB 2.0 and 3.0). I know the drivers work because I have flashed the core once before from this laptop, but for some reason it’s not showing up in the Device Manager so I can’t update firmware.

Any ideas about how to debug and/or connect to the Core? Any ideas are much appreciated :)!

Hey @hydrosquall, is the device in Listening mode (blinking blue) when you are using the iOS or CLI to configure wifi?

Hi Kenneth! When it is first plugged in, it is white momentarily, then it blinks green.

After I hold “mode down” down for 3+ seconds, it switches to blinking blue. I have the device manager open the whole time, and try “scan for new hardware” before and after being in Listening mode, no luck though.

It might be a USB cable issue… It should show up as a COM port or other devices (if driver is not installed)

Changing the cable fixed it, device shows up in device manager and I was able to configure the Core from the CLI. Thanks @kennethlimcp!!

1 Like