Core - solid blue after breathing cyan

Hi,
I have an original Spark-core that was working OK until today. Symptoms (after much reading and reseting of the device to try to fix it) : solid blue color led after appearing to boot normally ( breathing cyan mode). AFter about 2 ‘breaths’ it suddenly turns blue and stays there. I have:

  1. reset wifi (10 sec on mode button)
  2. reprogrammed via mobile (spark) app numrous times (after going into listening mode)
  3. As a last resort - I ‘factory reset’ the device by holding mode and tapping reset.
    This worked better than instructions that said hold both buttons down and later release the reset button.
  4. It seemed, again, to program the core. It went through the normal sequence of flashing including the pulsating cyan, but, in the end, went to solid blue color.

The docs say that it means the core ‘accepted credentials’, which should be a good thing but, in this casethe core is not recognized by the mobile app or on the build site.
I have not changed any passwords or keys.

I’m new at this, but I did spend time reading community topics and Particle docs to try to solve this before approaching the forums.

My thanks to anyone who takes time to help with this issue.

john

Do you have the CLI installed?

Hi Kenneth,
I don’t know if you work for Particle but I’ll assume, for now, that you do.

When I saw your response about ‘the CLI’…
I was dreading having to deal with anything ‘windows command line’ related due to nightmares from the past, but I knucked down and installed particle cli and dfu-util and zadig and worked through all the complications (like having to wait 5-10 min for DFU… to show up in Zadig). Finally I was able to get all the firmware updated and get the device reprogrammed but it was not showing up on build site or on the mobile app.

I had to find out how to get particle to divulge the ‘device ID’ so I could add the device on the build site. That worked and cascaded to the mobile app. I’m now able to use my core again but I have to say, when it is so painful and frustrating to fix I’ll probably use some other vendor of microcontrollers if this happens again.

Don’t get me wrong, I really appreciate your quick response and I have an electron and love that you are at the cutting edge of this field. I know you’ve worked hard to get here and probably will have a large following as your products mature, but without simple methods (no cmd line) to recover or reset from WIFI/Net issues it will be hard to recommend Particle products to customers who need real reliability and low maintenance.

Thanks for responding and best regards,

john

I’m just a slightly more active community volunteer and not part of the official team. :smile:

So can i confirm that your device is working properly now? I recommended the CLI as it is the more comprehensive tool by far to resolve majority of the issue. The installation takes a while and i agree but i’m glad you have it setup. @ me if you still have issues. Happy to work it through!

1 Like

First I’m glad to hear your device is up and running again :+1:
And we hope you’ll not turn your back on Particle just for this :weary:

I’m also only a volunteer like Kenneth and can only offer my personal two cent :wink:

But that “command line nightmare” is just something we Windows users got told/taught to be frightened of, Linux and Mac users seem to see this a bit more relaxed - partly because it just works a bit smoother there, I think.
Windows is just failing to have that last bit of “it just works”.

So it’s not really a bad thing to use a console program for tasks that don’t need fancy graphics but pack a lot of functionality in a “slim” program.

Even for Windows interna you are sometimes way quicker and straight forward via cmd than going the elaborate but nicely painted, windowed way.

Once you overcome the initial reluctance (as I had to too), you might find, you won’t want to miss the ease of use of CLI anymore.
And the driver nightmare you experienced is again rather MS’s fault than Particles.


BTW:

It might/should have been quicker by forcing a refresh of the list via the “Options - List All Devices” menue and/or interrupting Windows in its bound to fail attempt to install its own drivers.

Had it been there before? How did it disappear?
If your device really disappeared particle setup would have saved you things like searching for the Device ID, adding it to Build, …

Not all command line is bad, despite Windows having taught us so :wink: