Fatal: destination path 'firmware' already exists and is not an empty directory

Every time I attempt to add a library to a project in the Web IDE I get an error message when I compile.

For example, this project compiles just fine without the library, but fails when I add fashee-eprom:

Processing /workspace/starport.ino
Checking library flashee-eeprom…
Installing library flashee-eeprom 0.1.8 to /workspace/lib/flashee-eeprom …
Library flashee-eeprom 0.1.8 installed.
fatal: destination path ‘firmware’ already exists and is not an empty directory.
From https://github.com/spark/buildpack-base

What am I doing wrong?

@Darmitage, I just compiled one of the flashee examples without any problems. I compiled against both a Core and Photon target. I’ll try creating a dummy project and adding the library. One thing to point out is the fact that the library has not been upgraded to v2.0 so that may be a source of problems.

UPDATE: I created a new application, copied one of the flashee demo app code to it and added the flashee library to the app. It compiled without errors.

My Web IDE error message shows up regardless of the Library I am using. This appears to be something wrong in the plumbing :-). And it happens in both Safari and Chrome. And Clearing my cache doesn’t fix it.

Is there a Particle.io Cloud File System that I can access and find this elusive destination path “firmware” ?

@Darmitage, the Particle folks are looking into this. Have you tried compiling against 0.6.1-rc1?

Just tried that. Same error.

I had been using Bluz with 2.1.50 and just switched to an Electron with 0.6.1-rc2

I had a similar issue this morning. I originally tried 0.6.1-rc2 and had similar errors. I commented out the library include (PietteTech_DHT.h) in my case, then added again through the library manager and compiled with 0.6.1-rc1 and that worked for me.
Not sure exactly what the problem was, but I know they’ve been working with the Library manager and I think I may have had issues with 0.6.1-rc2 defining data types like Arduino does. ([PR #1216]1 Improved Arduino Compatibility (now supported by default, added PARTICLE_NO_ARDUINO_COMPATIBILITY=y command line option for disabling) Maybe double defining types?
Anyway, at work now, but will dig into it tonight at home.

Just FYI - We launched a new beta version this morning that now supports Libraries v2. You would have to upgrade to this version before the Libraries could be included in your bluz projects again: https://neighborhood.bluz.io/t/2-2-50-beta-3-pre-release-available/783

Even thought this is a beta release, it is quite stable as we have changed little and only added some new features (like iBeacon and reading battery voltage directly without an external GPIO connection) to the release.

I have the same problem with 0.6.1-rc1 and rc2. When I use 0.6.0 everything works.


I update Bluz to the new firmware this morning. No change. The Web IDE is still telling me that my firmware directory already exists and is not empty. This is try regardless of which hardware/firmware I use any time I attempt to compile with a Library.

Processing /workspace/starport.ino
fatal: destination path ‘firmware’ already exists and is not an empty directory.
From https://github.com/spark/buildpack-base

  • [new tag] 0.3.7 -> 0.3.7
    make -C …/modules/bluz/user-part all

Hmmm… ok, I am checking with the Particle team. I am not sure why you would see that issue, I am able to compile Libraries fine with 2.2.50-beta.3 in the Web IDE.

This warning doesn’t affect the compilation. We’re updating compile images so it won’t be visible in the future (some builds may see this until whole compile farm is updated).