Flashee-eeprom Library

I was trying to use the Flashee-eeprom Library by @mdma, but giving some error while using the Web IDE. Could someone help me to resolve this issue?

I was trying to use the sFlash_WriteBuffer but ended up with error: ‘sFLASH_WriteBuffer’ was not declared in this scope error. I tried ‘sFLASH_WriteByte’ also but with no luck.

Any idea what is wrong here?

UPDATE #1: I was trying Particle Core, not Photon

UPDATE #2: After logging out and selecting a Core again solves the issue. So it seems that the problem is with the selecting the Current Device to Flash. When we select Photon, compiling will be different then when we select Core and it should be. So in my case for some reason even if I selected a Core as the device to flash, the issue was there, but after logging out and log in again solved the issue. I am not able to recreate the issue again, somehow it came and disappeared.

1 Like

I can confirm the FlashEE library doesn’t compile on Photon, I get the same error.

I can also confirm that the WebIDE has some bugs related to switching between devices. It works, unless you have a failed compilation and then try to switch libraries and then devices, then the devices aren’t actually switch until you reload.

Flashee on the Photon isn’t presently supported since there is no external flash storage on the Photon. I will be updating it over the coming days to work on the P1 which does have 1Mbyte of external flash.

If the Photon is ever supported, it will be simply to access the 2KBytes of emulated EEPROM, so that code is portable across platforms.

1 Like

Hey @mdma,

Any update on access to the external flash on the P1?
Is it still accessible via dfu-util in the same way it was on the Core?
If it’s not up, I’d love to try and contribute. Any low level chunks of fw/docs that you could point me to?


P1 is supported in 1.8.0.

1.8.0 of the cli? Sorry, I meant to ask about the firmware.

Is there a firmware library that allows access to the external 1MB flash on the P1?

version 1.8.0 of flashee provides access to the 1MB flash on P1. Also, you can access the flash directly on a P1 since 0.4.4 of system firmware.