[SOLVED]Library - No such file or directory error web IDE

Hi,

using the web IDE to add in a library (any library it seems) continuously spits out the same ‘no such file or directory’ error. Even with the build in examples! Adding in the library manually in the tabs work BUT gets problematic with more complex libraries like fx AssetTracker that in turn relies on several other libraries. I can see that this is a known issue, yet I have not been able to find a solution.
Any ideas?

If you search the forum, you’ll find that the first question for this often is: "What system version are you targeting?"
And subsequently: “Have you tried any other?”

1 Like

yes I did see that, but assumed it to be fine. It is 0.49 as is device (electron).

Well, “have you tried any other?”

ok so I tried with a newer system version, from 5.3 onwards it compiles, however it also says that I if I flash it onto the device it will go into safe mode… hmmm so I guess I will need to update the firmware first, which kinda sucks as I bought these not too long ago

Isn’t that the whole point of IoT; to be able to update your devices remotely, without being stuck to the factory default? The fact that the system firmware is upgraded means that improvements have been made, which I’d consider to be a good thing. Also, keep in mind that they might come from inventory, rather than directly from the factory. That, too, plays a role in a ‘dated’ version.

Using the Particle CLI, the process should be as simple as issuing Particle update, and Particle flash --usb tinker, both while in DFU mode.

BTW, I doubt that your device was 0.4.9 since this version never was released for Electron :wink:
And why stick with an ancient version (even 0.5.3 is outdated).

On the other hand I can understand your point about why a freshly bought device still comes with an old version, but there are two factors to consider.

  1. Stocks don’t get dumped just because a new FW was released
  2. Incorporating a new FW in a perfectly fine running manufacturing process bares risks that don’t have to be taken due to the easy upgrade process once sold - on the other hand doing so would still not grant protection against point 1.

yeah, its ok I was just eager to get going and am now on day two of just getting it to work and I’m a noob with some basic programming skills so doing these things require lots of searching and trying out stuff I don’t really understand etc. :frowning:

bought it of a German vendor so I guess it might have been on the shelf for awhile…

so I updated it with @Moors7 commands, apparently successfully but when I go to the IDE it still says 0.49, is there a command to check it via terminal?

And thanks for helping :slight_smile:

You can put the device in Listening Mode and run

particle identify

The Web IDE sometimes needs some incentive to update its idea about your device.
One way is to go to the settings pane (bottom left cog icon) and CLEAR CACHE

In order to updateto the most recent version you also need the newest CLI (currently 1.22.0)

fantastic 0.6.2 - would be great to have that command at the Ref page

Is it not? :confused:

https://docs.particle.io/reference/cli/#particle-identify

But I see what you mean, the docs only talk about the device ID (which is the only info for Photons) but miss out the extra info for Electrons.

yes just needs to mention firmware vers, anyway clearing cache didn’t change it but as long as its on there I guess all is good :slight_smile:

and after a restart of the electron the IDE updated the version as well.

2 Likes