Library include error in Web IDE

Recently, I am include the library for my project build.

#include "flashee-eeprom/flashee-eeprom.h"

And it is so often that when I change a file (I have 5 files), then the error will pop up saying the above header file is not found. I already confirmed that all my #include file does not have any “//” at the end.

When there is error, I have to delete the library and then add back the same library again.
Anyone have ideas ?

Here is the error message… I have a different file “DataFormat.cpp” which declare the Device, so that I had include in both files.

If I logout and login again,the library is not in IDE… So some how, it got deleted when I change files and rebuild.

In file included from …/inc/spark_wiring.h:30:0,
from …/inc/application.h:29,
from DataFormat.cpp:5:
…/…/core-common-lib/SPARK_Firmware_Driver/inc/config.h:12:2: warning: #warning “Defaulting to Release Build” [-Wcpp]
#warning “Defaulting to Release Build”
^
DataFormat.cpp:8:43: fatal error: flashee-eeprom/flashee-eeprom.h: No such file or directory
#include “flashee-eeprom/flashee-eeprom.h”
^
compilation terminated.
make: *** [DataFormat.o] Error 1

I’m having a similar problem, my project will compile fine over and over and then suddenly it complains of a missing file related to the one wire library. If I remove and re-add the library then the error may go away for a bit. I’ve never had this problem before but I’ve had to remove/re-add the library 5x in the last hour and it’s getting annoying.

In file included from ../inc/spark_wiring.h:30:0,
from ../inc/application.h:29,
from hvac_controller.cpp:2:
../../core-common-lib/SPARK_Firmware_Driver/inc/config.h:12:2: warning: #warning "Defaulting to Release Build" [-Wcpp]
#warning "Defaulting to Release Build"
^
**hvac_controller.cpp:2:29: fatal error: OneWire/OneWire.h: No such file or directory
#include "application.h"**
^
compilation terminated.
make: *** [hvac_controller.o] Error 1

I just realized after I get this error if I refresh the IDE in my browser that the included library is no longer part of my project. So I do have the same problem.

Hi @Fragma,

Can you PM me the url of the project you’re building where you’ve had to re-add the library multiple times?

Thanks,
David

1 Like

Hey @Fragma @Dilbert ,

We’re looking into this and want to solve this issue, sorry for the troubles and thanks for bringing it up. This issue appears to come up intermittently and I haven’t been able to replicate it myself yet.

When you’ve encountered this error did you have multiple browser tabs open with the same Spark IDE app?
I speculate that could contribute to the frequency of this error popping up.

Also, if you know of a way to reliably recreate the error, please let me know.

Thanks,

-joe

2 Likes

I only have the IDE open in one tab. While I cannot force the issue it is easy to reproduce. Every 1-5 times I click verify button after making changes I’ll get that error. The change can be minor like adding a blank line; just anything to get the compile process to run again.

@Fragma, can you please send me your build ide url with the app id at the end so I can check the database / logs?

Thanks,
David

My workaround is getting less reliable, a few minutes ago I got the error and re-added the libraries. I clicked Save and then Flash and again I got the error about the missing library. I tried again and had the same issue, the 3rd attempt did work.
So my exact process was to add the spark-dallas-temperature library, then the OneWire library, and then remove the now duplicate include lines from my code, hit save and then hit flash. One of the times I clicked the <> (Code) button in between save and flash to see if the libraries were still there, they were. This process normally works but it failed twice in a row with 0 successful compiles in between. Generally I use Verify before Flash but I skipped it this time in case that was the issue.

Having same result… The IDE seems crashing more now. btw, I just email the URL link to Dave.
Looks like it is completely dead. Would not able to build anymore.

In file included from …/inc/main.h:37:0,
from …/inc/spark_utilities.h:30,
from …/inc/spark_wiring.h:33,
from …/inc/application.h:29,
from DataFormat.cpp:5:
…/…/core-common-lib/SPARK_Firmware_Driver/inc/hw_config.h:37:20: fatal error: rgbled.h: No such file or directory
#include “rgbled.h”

Heya @Dilbert,

We hit a snag while updating the firmware branches just now, I posted about it here: http://status.spark.io/

Thanks,
David

2 Likes

I just tried and result is the same. The library is missing and need to add again.

Hi @Dilbert,

In this case I was referring specifically to the #include "rgbled.h" error. We’re still working with the build IDE team to fix that race condition.

Thanks,
David

Since last night, I discover it getting into other error condition. Once the error occur, the recent changes in files will be lost. Meaning the “saving” does not work.
This is even worse as I need to remember what had been just changed for a build.
Use my project to try, it is pretty easy to reproduce today.

1 Like

Hey @Dilbert , @Fragma , @Julian : Before I roll out for the night, I wanted to give you an update on this library include issue you’ve reported and it’s current fix status.

It’s a tough one to replicate in a system not under load. I was able to observe and confirm the issue in the data underlying the build URLs you guys shared and had a strong hypothesis of a race condition in the backend code. I made some tweaks to the underlying code, added some tests, and deployed this to our staging instance. Even though everything looked good, I didn’t want to deploy to “deploy to production and run” for the weekend, without being around to support, in case things weren’t quite right. Thanks for your patience to rock a workaround (re-add the libraries) until this gets fixed. The plan is to ship this to production on Monday or Tuesday–will ping you guys when we do.

Have a good weekend!

-joe

4 Likes

Hey Joe

Thank you for the update. I am sure it will not take you long to figure out the issue. I appreciate that it is only when you get the system out in the “real world” and under stress that the cracks acn start to appear.

I am, as I am sure the others in this post are, more than happy to assist in any way to get this sorted. The library feature is a defining benefit of the spark core platform and it is important that this gets sorted, as I am sure it will.

Thanks for your’s and @Dave’s hard work.

Cheers,

Julian

1 Like

Hey Guys,

I just deployed the fix for this issue to production. Please let me know if your library includes disappear again or you have any other related troubles.

Thanks for reporting this and thanks for your patience, it’s really appreciated!

-joe

1 Like

Thanks for the fix. So far I haven’t seen the issue return. I’ll let you know if it does, otherwise you can assume all is well :smile:

Same here. Did not see problem today.

@jgoggins I am having issues including libraries and it sounds like its the issue everyone else here is having. Mucho annoying.

Suggestions?