Electron won't publish events


#41

It has been working for me the last 12h or so.


#42

@ScruffR @Peekay123 Any ideas as to what is causing these publish errors?

I have a regular test going with an Electron, but I’m not sending data via a Particle Publish but instead of sending data to Ubidots via MQTT and there have been no gaps in cellular and data service. So I can say that the Cellular data connection in my area has been pretty solid which leads me to believe the Publish issues are on Particles end.

Just curious what is causing the publishes to not go through since I plan on sending most data via Particle Publish events in the future until we can send data using TLS support.

@Dave Any progress on getting the direct TLS going so we can send data directly to Azure or Amazon without needing to push it all through the Particle Servers which adds to your overhead?


#43

That may be answered by @bryce who did restart some services to cure things.


Electron indicating 'connected' yet not publishing
#44

And I am interested when it will be enabled support for TLS. Arduino already have https://www.arduino.cc/en/Reference/WiFi101SSLClient
@Dave said that they work internally to support but it is still in an early beta stage.
[Fixed] Webhooks callbacks are not reliable!
I am particularly interested whether TLS support will be enabled for Electron?


#45

(@bryce ?) I appear to have lost touch with two Electrons in the field – no data being published. They’ve been running fine without issue for weeks. This looks similar to the issue with the device broker (yesterday and a few weeks ago). Can someone check, please?

[update] They’ve been running non-stop since November 12th and appear to have stopped publishing at 15:05 (EST) today.


#46

@ctmorrison Give it a try now.


#47

@bryce, looks like it’s back online at about 16:27 EST. Is there anything I should be doing differently to avoid this issue? Thanks for the help!


#48

Not your fault in any way, so nothing you can do unfortunately. We are doing our best to add alerts to catch this problem early and to solve the root cause. It has thus far proven tricky to replicate in test environments.


#49

Sorry about the slow reply here, been traveling / sick these past few days. The team is tracking down a sneaky issue that is hard to catch / predict that sometimes impacts a small percentage of electron users. Like @bryce said we’re in the process of adding more metrics and alerts to help us catch it in action. Happy to share more details when I know more.

Thanks!
David


#50

I’m am experiencing this exact “No Publish” of events. I’m running 0.6.2. Yesterday was the first new Electron was connected to the Cloud with Publishing turned ON. It published its first event at 10:01am which I captured, 2 more events occurred by 10:40am but none since then.


#51

See Electron won't publish events

Problem seems to be back.


#52

Can you provide some more details? System firmware version, user firmware, etc?


#53

System version 0.6.2, not sure what you mean hear, a copy of my app? My problem sounds very similar to the link I posted from the forum 8 months old.


#54

Hi @ovro67,

Try refreshing the browser page, and make sure you’re not publishing more than one event per second on average? I appreciate the heads up, but I’m not aware of any wide scale publishing issues right now.

Thanks,
David


#55

This Election was a replacement, see Rickkas 10/26… I had to contact him since I was unable to make a connection. He had me in a special app and then send him the terminal output. It turns out he had to do some special magic at his end. He said the device was misconfigured and then it worked.
What if I copy that simple publishing app from that post to see if that will generate an event?
My app only sends one combined event with 7 data points, then it goes to Sleep for 20 minutes and repeat that event with new data.
The ios app does show any events being published but my cell data usage is increasing.
What steps should I try to figure this out? I have a photon which I developed my code on before receiving the Electron and publishing worked with no problems. I’ll try connecting it this afternoon to see if events occur on the console. Using chrome now, OS X.

I copied CJ_'s app and flashed it to a new Photon running 0.5.3 and got the following.

**void setup() **
**{ **
pinMode(D7, OUTPUT);
}
**void loop() **
{
digitalWrite(D7, HIGH);
Particle.publish(“test.event”, “test.data”, 60, PRIVATE);
delay(1000);
digitalWrite(D7, LOW);
delay(10000);
}
The new Photon has no problems publishing events. However the Electron will not publish any test.data events.

11/5/17
Just discovered this after command, particle list,
Downloads ron$ particle list
easter_puppy [xxxxxx] (Photon) is offline
ferret_zombie yyyyyy8] (Photon) is offline
keet-data2 [zzzzzzzz3] (Electron) is online

keet-data2 shows online even when disconnected. Also on shows breathing cyan 9 minutes after being disconnected on iOS app.

Thanks,
Ron


#56

Hi @ovro67,

I think those delays are what’s tanking your performance, try something like this instead. It’s a little goofy because of the extra blink off clause, but I wanted to mirror your example program as closely as possible:

unsigned long lastPublish = 0;
unsigned long lightOnTime = 0;
#define PUBLISH_DELAY 10000
SYSTEM_THREAD(ENABLED);

void setup() {
    pinMode(D7, OUTPUT);
}

void loop() {
    unsigned long now = millis();
    if ((now - lastPublish) > PUBLISH_DELAY) {
        lastPublish = now;
        
        digitalWrite(D7, HIGH);
        lightOnTime = millis();
        
        Particle.publish("test.event", "test.data", 60, PRIVATE, WITH_ACK);
    }
    
    if ((lightOnTime > 0) && ((millis() - lightOnTime) > 1000))
     {
        lightOnTime = 0;
        digitalWrite(D7, LOW);
     }   
} 

Can you try something like that and let me know if that works better for you?

Thanks,
David