Electron won't publish events


My electron was working properly publishing data every time I initiated an event from a DO Button. It has stopped publishing so I made a very simple program to test Particle.publish. Running this code I can watch the LED on the electron flash as an indicator the code is running but the console logs still don’t show up. Can anyone offer some advice to get them working again?

So far I have updated from 0.4.8 to 0.5.3 to 0.6.0 with no change as well as unclaiming and reclaiming the electron. All other code runs normal, sensors are reading etc.

void setup() 
pinMode(D7, OUTPUT);

void loop() 
digitalWrite(D7, HIGH);
Particle.publish("test.event", "test.data", 60, PRIVATE);
digitalWrite(D7, LOW);

Code Not Working after 15 Days in the Field
Code Not Working after 15 Days in the Field

Try adding


before the Particle.publish and see if it makes any difference.


I just tried adding the Particle.connect in the setup as well as in the loop directly. No change both ways. Still no publish.


I’m just guessing here but try taking the . out of the “test.event” publish name and see if that changes anything.

Is the Electron breathing Cyan color showing it’s connected to the cloud?


Still no change. It’s breathing Cyan, tinker works, other code runs fine and can flash OTA or via CLI. I’m at a bit of a loss as I have a photon here as well that seems to be publishing just fine.


Are you checking the correct even stream?
Is this Electron claimed to the same account as your Photon?
What if you add some Particle.function() or Particle.variable() in your code? Do the show up in particle list?


If you power off the device and power it back on you should see a “Electron came online” event in the console.particle.io/logs page. As @ScruffR said, it would be good to double-check that you are logged into the console with the account that also owns the Electron (and therefor looking at the “right” event stream)


I am logged into the correct account (the only account I have) and the electron is claimed. I am able to see particle.function and particle.variable in the iphone app but can’t see them on the console anywhere. There is no event when the electron comes online, however, it always shows the blue dot beside it on the console page and the iphone app says online tinker when it is offline. I am about to deactivate the sim, release and reclaim the electron to start fresh. Another thing I’ve noticed doing so, is when I unclaim the electron, it shows up again as soon as I refresh or return to the devices page.


What Webbrowser are you using on the PC?


Google Chrome Version 54.0.2840.99. It was working fine up until the 23rd of October when my console shows the last time the electron was online successfully.


I have exactly the same issue with my second Electron. With my first Electron everything works fine. Yesterday, I setup my second one but it don’t publish any events (also no “device online” event).

The setup, firmware and sketch are exactly the same.

At the beginning I had the “red burst” issue. I solved this with the following commands in the DFU mode.

particle login
particle keys doctor (deviceID)
particle keys server

I also tried other solutions of the community but nothing helps. Is there any fix for this issue?


Does it get online? Can you control it remotely (functions, variables, flashing)? You can check here for functions/variables.

Are you sure the code is actually on the device and running?

Such as? No point in us telling you the same thing again.


Yes the device comes online in your dashboard and also in the device list of particle. Online the “online event” is missing.

Yes I’m sure that the code is running correctly. I can communicate over Serial.

I also tried:

  1. particle update
  2. Upgrade firmware with the exe tools (already done before testing code)
  3. particle flash --usb tinker
  4. dfu-util -d 2b04:d00a -a 1 -s 3298 -D server-public-key.udp.particle.io.der (key from http://server-public-key.udp.particle.io/)

Now I tried to unclaim the device via web console and claim it again via particle cli during breathing cyan:

particle device add (device id)

But this results: Failed to claim device, server said: Device is not connected

Claiming with https://setup.particle.io/ still works but with the same issue of no events. Also the signaling fails.


I’m having this same issue as well. My Electron was running fine in the field along with two other “identical” Electrons and this one seems to have fallen off the face of the earth. It is no longer publishing events. The others are working fine. I re-flashed the application for giggles and did a “particle update” just to be sure.

When I power on the device, it appears to attach to the cellular network and breaths cyan appropriately. However, I see absolutely no evidence of the device coming online in the logs. Nor do I see any evidence of the webhook being called via Particle.publish().

Again, this device was running for weeks just fine all alone with no one touching it. It went offline at 1:11AM EST today. Was there any special platform maintenance being performed at that time?

[update] This same thing may have happened to one of the other Electrons last week. I assumed it had gone offline for some strange reason, but it was breathing cyan just fine when I opened its enclosure. I disconnected the battery and power adapter and restarted it and it came back online just fine. However, it had been offline for a couple days.


I tested a complete new Electron few minutes ago and everything works with. The issues with the other Electron still appear.


I have the same issue. It was working fine last night, but not today.

I contacted Support , no answer yet.


Hey all – thanks for reporting this. Going to ping internally to see if we can dig up some information about what’s going on.


@will Do you need the IDs of the Electron which fails?


That would definitely be helpful!

Are you still seeing the issue? We had a reported incident this morning with respect to webhooks and integration latency, so I would not expect it to impact publish events.


I send you a PN with the device ID. There error is still there.