Electron won't publish events


#21

Still the same problem at my end. I tried to reflash the tinker firmware to rule out any issue with my own code. Always the same:

  • I get the breathing cyan and for 1-2 minutes , it looks online. At https://console.particle.io/devices I see “Last Connection” updated to the current time. For a few seconds I can even list functions functions:
    elebel 3f00280XXXXXXXXXXX is online
    Functions:
    int digitalread(String args)
    int digitalwrite(String args)
    int analogread(String args)
    int analogwrite(String args)

but calls always fails ( as well as publish in other tests)
$ particle function call elebel digitalwrite D7,HIGH
Function call failed Timed out.

I never lose the breathing cyan even though the device is obviously not really connected. The “Last connection” time gets updated after some time, but the issue remains.

The most annoying part: my cellular data usage is quickly increasing (caused by the periodic reconnection I guess)…

Not sure what else to try.


#22

@elebel, what system firmware are you on? Can you also PM me your device id?


#23

Hi Particle, there are now several threads with VERY similar symptoms regarding Electrons appearing to be online, but you can’t interact with them, even with Tinker.


#24

@ctmorrison, the Elites have this on our radar and pushing investigation.

It will be more helpful if you can pm me the information of particle serial identify to help get to the issue.

Thanks!


#25

That won’t notify them, but it’s already being discussed as we speak.


#26

@kennethlimcp and @Moors7, I apologize, but it’s getting pretty frustrating trying to move forward with development with this in the way. I truly appreciate all the help that’s being provided.


#27

@ctmorrison, sorry for the frustration and thank you for your patience. The Elites have this on our radar.


#28

@ctmorrison, how recent did you upgrade to 0.6.0?


#29

I upgraded that device yesterday in hopes that it would help resolve the problem. Prior to that it was on an older version (like the other 4), but I don’t recall which version. The problem surfaced when it was on an older version.


#30

Hey folks! We did some investigation this morning and believe we may have found the root cause. The issue was not consistent across all v060 devices, so we don’t currently believe it’s a firmware issue.

The device IDs that were reported had gotten into a weird state with our device broker so we restarted the service and it seems to be improved. We’d very much appreciate if you’d check the affected devices and let us know if the symptoms are resolved!


#31

It’s working now. Thanks. Anything I could do on my side to prevent this from occuring again?


#32

@will, the device that was acting up for me started working in Tinker and so I reflashed my application code and it’s now working. Thanks to all who helped get this resolved!!! As @elebel asked, if there’s something I should or should not be doing to avoid this in the future, please advise.


#33

Hey folks – glad this issue seems to be resolved. Nothing for you to do on your side – I’m working with our cloud team to add an alert so that we can proactively detect these kinds of issues in the future and respond more quickly. It will also help us discover a root cause that will prevent it from happening in the first place.

Your help is super duper appreciated, so thanks for helping us with this one!


#34

Hi, I got a similar issue.

I have an electron, which runs a small app, publishing an event and then going to deep sleep for 10 min.
It worked perfectly for a day or so, but then events stopped being published.
It logs my data to Things Speak, so there is an internet connection, and the LED is breathing cyan.
But no events are published, it cannot be flashed OTA and when I signal it from the IDE it is not responding.
I loaded tinker, but it was not responding to function calls either.

On the other hand, the ‘last connection’ field in the console is working, and lists the correct time the module came on line.

Could you please advise?

Many thanks


#35

@plim, which version of firmware are you running? Posting your code might help also.


#36

Hi,

I am using v 0.60.

As I was preparing a cut down version of the code, I begun to suspect that the time between Particle.publish() and the end of my loop (I also sent data to other logging engines) was too much for the keepAlive() value of my operator.
Calling Particle.process() right after Particle.publish() and setting Particle.keepAlive() to 30 sec solved the issues.

30 sec is a low value, but when I used a value of 60 sec I had issues with OTA or signalling the device via the IDE.
I will test if for some time and report any issues.

Have a nice day
Plim


#37

It appears I’m experiencing this issue, again, with a different Electron. It will not publish events. I’ve hacked the code inserting several Serial.println() calls immediate before the Particle.publish() calls, but even though I’m seeing the output on the serial monitor for the print statements, I never see anything from the publish calls. I’ve also gone in and added numerous Particle.process() calls immediately after the Particle.publish() calls, but without any associated benefit. Are we having the same cloud issue we experienced a few weeks ago?

[update] Also…all published variables (and functions if they’ve been called) show as “Error” on the Particle iOS app.

[update] Tinker will not work when flashed to this device


#38

Particle will investigate shortly


#39

@plim & @ctmorrison, can you check now?

Update:
No feedback? Seems to be fixed tho’ - closed for this time then.


#40

@ScruffR, I responded in a PM to @peekay123. Yes, it seems to be working fine now. Thanks.