Electron stuck in DFU mode after --force

When flashing to my electron on Windows the only way I could ever get it to work was by activating DFU mode and flashing through usb with particle flash --usb firmware.bin.

For some reason when I tried to flash the firmware file I got from the WebIDE i got an error that said incorrect platform id. The command prompt suggested that I try the command “–force” so I did but afterwards the electron now flashes yellow even when i restart the electron.

To try to fix this problem I used some commands not really knowing what I was doing
particle flash --usb cc3000
particle flash --usb tinker
npm install -g particle -cli

Now when i try to do particle flash --usb firmware.bin I get the message:
"‘particle’ is not recognized as an internal or external command, operable program or batch file"

So I can’t even use particle commands anymore now? I have no idea what to try next or what my problem even is anymore.

Flashing cc3000 to an Electron is a bad idea, since that is the firmware for the TI WiFi chip that’s only used on the Spark Core.
I’d also assume that your original incorrect platform ID was actually incorrect (I guess it was 0 - which is Core - and not 10 - which would be the Electron), maybe because you didn’t target an Electron when you built the binary.

And usually npm install -g particle-cli happens before the other two commands, since that would “install” the particle command, but you already had that installed.
The only useful command in that respect would have been npm update -g particle-cli which you would also do before using particle.
To install CLI properly again you might want to look here
https://www.particle.io/cli

Maybe you try the firmware updater

or try the long way outlined here

It’s no good just hacking away when you don’t quite know what you’re doing :wink:

Thank you Scruff. Reinstalled the cli with your help.

As for my other problem, I was able to get the binary program to flash to the electron after I made sure I had the correct device selected as you said. However the LED is still flashing yellow even if i hit the reset button. This is what I got when I flashed.

Have you tried the Firmware Manager?

The system firmware consists of two (in future three) parts which habe to be flashed in correct order and need to be consistent.
If that is not the case - as might be due to your previous flashing oddysey - the device will stick in DFU Mode till that’s settled.

Hey I don’t see anywhere to download the firmware manager.

Maybe the link was removed or i’m just missing it?

I’ve updated the link, which broke during last docs update

Sorry for that :blush:

https://docs.particle.io/guide/tools-and-features/firmware-manager/electron/

Okay I tried the firmware manager and it says i need to connect via usb which I did. My laptop definitely is seeing the electron in the USB port. Any other suggestions?

OK, that seems as if FM is not recognising it as Electron (maybe due to it’s muddled state).
So you might need to download these
https://github.com/spark/firmware/releases/download/v0.5.2/system-part1-0.5.2-electron.bin
https://github.com/spark/firmware/releases/download/v0.5.2/system-part2-0.5.2-electron.bin

And execute this

particle flash --usb system-part1-0.5.2-electron.bin
particle flash --usb system-part2-0.5.2-electron.bin
particle flash --usb tinker