Electron shown in Device Manager but CLI and Workbench cant find device

Hey,
quite new to Particle.
I have done the starting up tutorial, but I cant flash the board. The device is shown as Photon DFU Mode in the device manager -> not as Electron (because the board is an electron). But when I am using CLI with

particle identify

it shows: No Serial port identified
I already tried reinstalling the drivers.

particle identify

only work when the electron ist put into listening mode. But flashing is not working as workbench cant connect to the device (neither in DFU or in listening mode).

Thanks

Found the mistake.
I gave the device a name in workbench, which could be found.
After deleting the name it worked

That is the expected behaviour.

particle identify is only supposed to work in Listening Mode.

Can you show a screenshot of your Device Manager window while the device is in DFU Mode?

Workbench is (by default) using DFU Mode for wired flashing, but you can also use CLI
for DFU Mode (preferred way)

particle flash --usb yourFirmware.bin -v

for Listening Mode

particle flash --serial yourFirmware.bin

Thanks,
that helped.