Serial suddenly not identifiable, boards are flashing/running

I am using the Adafruit Boron LTE board. I have been using it for months and have had no issue compiling/flashing/running the boards and using particle serial with the particle CLI.

Just today, suddenly the serial is no longer working. I keep getting "No serial port identified". I should mention that I have compiled and flashed the board with the SAME cable and I can verify that the board is working and sending data to the cloud.

Did something change recently?

Windows, Mac, or Linux?

Are you flashing from Workbench? Using what command palette command?

Or Particle CLI? With which options?


Using windows.

I am flashing from visual studio code with the particle workbench.

I am flashing with whatever the default settings are.

The board is flashing with new code, i can verify this with the cloud. the device is operating fine just cant connect serial for some reason. Here is the serial part.

void setup() 

	waitFor(Serial.isConnected, 15000);


So that's the CDC serial device, which is unchanged on the Particle side. Are you using the Workbench Particle: Serial Monitor, Particle CLI particle serial monitor, or a different terminal program?

I'd first check to see if the device shows up in the Device Manager. There's a possibly a Windows device driver issue. The tips in this document may help.

The device shows up as USB Device (comX) in the device manager. I am using "particle serial monitor". In-fact, up until I just loaded in some new code earlier, the serial was working fine.

I'd say about 30 minutes ago I was running serial fine and then I loaded in new code, which added in a simple if statement, then the serial did not work.

Also, I removed that same code, uploaded again, still no serial.

Yeah, so I am also using a Particle Boron with Workbench and got the same exact issue. Did someone find a fix for this?

did you notice this issue pop up recently only? or is this your first time using it

This is very recent! I have been able to use Serial before, but not now all of a sudden!

So something may have happened recently, i guess ill need to dig into the updates

I did update the cli, maybe that has something to do with it?

If i did update the cli, I didn't realize i did

Sometimes, auto-update is on. You should check that.

I have got the same problem since 2 days on all devices. I tried to reinstall the particle-cli and the drivers, but still the same error: No serial port identified. The only way at the moment to connect the devices over serial is with Putty. At the device manager the device is also recognized on the port.

Perhaps this is the wrong place to post this, ill make a post on developer tools

BIG UPDATE!! There is a new update for particle-cli: 3.16.0.
When I updated to that, the serial monitor worked!!

1 Like


Did it work for you too?

Hi, yes, particle update-cli should resolve the issue.

We noticed this as well in our Internet of Things class a week ago Monday (using Photon 2) as well. In addition to the new CLI fixing it. For some reason, we were able to do a

particle usb listen 

and it resolved it even before the CLI update. Which was interesting as manually putting in Listen Mode (holding the Mode button) did not resolve it.