Electron: Not entering safety mode


I have an Electron that will not enter into safety mode. So far I have tried removing and reinstalling the SIM card, using the particle device doctor on CLI and power cycling (even cussing at it doesn’t work ;)). The Electron will start up then rapidly flash light blue. Any help would be appreciated!

Safe mode (breathing magenta) requires a working cloud connection. Since you’re stuck at fast blinking cyan, you’ll never get to safe mode, since you don’t have a working cloud connection yet.

It is possible that you have corrupted device keys. You’ll need to have the Particle Command Line Interface (CLI) installed, so if you have not installed it yet, follow the instructions here:


if you are using Windows, make sure you use the Windows CLI Installer link and skip the other steps.

Put the Electron into Listening mode (blinking blue) by holding down MODE until it blinks blue. Then issue the CLI command:

particle serial identify

Save the Device ID; you’ll need it later.

Then put the Electron in DFU mode by holding down both the RESET and MODE buttons, releasing RESET and continuing to hold down MODE until it blinks yellow and issue the commands below, in order.

particle keys server
particle keys doctor YOUR_DEVICE_ID

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you have used the CLI installer as described above, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

There are additional tips for a missing openssl error on this page, including tips for Mac OS X and Linux.

You could also try the cloud debugging tool to actually see why you can’t get past blinking cyan:


Thank you, I’ll try this. However, it is now blinking red.

In that case, do this first, then if you still don’t get to breathing cyan, try the other steps:

Put the Electron in DFU mode (blinking yellow) by holding down RESET and MODE, releasing RESET and continuing to hold down MODE while the main LED blinks magenta until it blinks yellow, then release.

Then enter the command:

particle flash --usb tinker

It’s also a good idea to put the Electron back into DFU mode (blinking yellow) and do:

particle update

The first suggestion worked! Thank you! So did I corrupt the device keys then?

1 Like

Most likely yes if that solved the problem.

1 Like