Electron disconnected from the cloud, blinks fast cyan

My electron stopped connecting 2 weeks ago after being on for over 4 months. I reset it numerous times and still doesn’t breathe Cyan. I am running a third party ATT sim and have reflashed the ICCID and still wont breathe cyan. I still pay for a particle sim so i put that in and reflashed the ICCID for that but it acts the same. Then i tried the one from my ipad and it acts the same, now im back to the original sim that was working for the last 4 months.

It starts green for a few seconds, then flashes cyan at like 10Hz for 10 seconds or so, then flashes cyan at 50Hz for about a minutes then finishes off with a few red flashes before starting back into the cycle again. Ive been fighting this thin all weekend and am at my wits end here. I sent an email to the particle team but i really want to figure this out! Any help would be appreciated.

I have tried the following as well:
I tried particle keys doctor but return this error:

Johns-MacBook-Pro:/ johnayer$ particle keys doctor 570040000c51343334363138
Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
Error creating keys… Error: Command failed: openssl ecparam -name prime256v1 -genkey -out 570040000c51343334363138_ec_new.pem
570040000c51343334363138_ec_new.pem: Permission denied

also ran:

Johns-MacBook-Pro:/ johnayer$ particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

> Your device should now restart automatically.
> You may need to re-flash your application to the device.

Yup, your thought about keys is probably right, but you need to get the OpenSSL call to succeede.

How about sudo?

You can also try particle keys server first.

1 Like

Psudo worked, back to life and breathing once again! Thanks again @ScruffR , your always making my day!
Johns-MacBook-Pro:/ johnayer$ sudo particle keys doctor 570040000c51343334363138
Password:
Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
New Key Created!
Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
Saved!
checking file 570040000c51343334363138_ec_new.der
spawning dfu-util -d 2b04:d00a -a 1 -i 0 -s 3106:leave -D 570040000c51343334363138_ec_new.der
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device…
ID 2b04:d00a
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000c22, size = 122
Download [=========================] 100% 122 bytes
Download done.
File downloaded successfully
Saved!
attempting to add a new public key for device 570040000c51343334363138
submitting public key succeeded!
Okay! New keys in place, your device should restart.
Johns-MacBook-Pro:/ johnayer$

1 Like

What’s does it mean when your device shows as active in the console but not under devices in the build? I flash OTA because I have plenty of data and it’s just easier but it’s failing to connect even though it shows online in the console.

EDIT: Looks like i has flashed into tinker mode, when i rebooted into safe mode i was able to flash my code even though the BUILD didn’t show i was online. I wish that indicator was more trustworthy, its often indicating devices on that are off and vise versa.

That’s something we are working on. It’s hard to have an accurate indicator and at the same time not burn a lot of data :frowning: