[SOLVED] Electron Rapidly Blinking Cyan - Will Not Connect

I am trying to get my Electron to stop rapidly blinking cyan. The current firmware version is 0.4.8. I was trying to update the firmware, but it doesn’t seem to take. I can get it into DFU mode, but not safe mode. If I try to put it in safe mode, it will blink magenta a few times then go white, green, and then go back to rapidly blinking cyan. Any help getting this online would be appreciated.

How were you doing that and how is it ‘not taking’?

I used the particle device upgrader apps and also the particle CLI on my mac terminal. The upgraders said that the upgrade was successful, but the particle build webpage said I was still on 0.4.8.

The electron was connected to the cloud, but now I cannot get it to connect, and it is rapidly blinking cyan.

There is a “bug” in Build which renders that info useless, unless you once performed a OTA update via Build to have Build pull in the latest info about your device.
You should use particle identify or particle serial inspect to find out what system you’ve got installed.

Can you post a video (e.g. YouTube link) of your attempt to enter Safe Mode?

Sorry about the delay. It seems that I cannot see the device. I have tried multiple USB ports and cables. Here is what I get:
Bens-MacBook-Pro:~ benstill$ particle identify

! serial: No devices available via serial
Bens-MacBook-Pro:~ benstill$ particle serial inspect

! serial: No devices available via serial
Bens-MacBook-Pro:~ benstill$

Here is a link to me trying to put it in Safe Mode:

I was also able to put it into Listening Mode (blinking blue) and try particle identify and particle serial inspect, and I got the same “No devices available via serial” result.

You don’t seem to leave a lot of time for the rapid cyan phase :wink: be more patient!
But immediately at the start of the video, isn’t that a red burst ?

If so, try this (in DFU Mode)

particle keys server
particle keys doctor <yourDeviceID>
1 Like

Yeah, I’ve tried waiting over 30 minutes several times to see if it would start breathing cyan, but it never snaps out.

It is a red burst. The commands seem to run, and the electron restarts, but it then goes back to rapidly blinking cyan.

Also, I tried unclaiming the device, which removed it from my device list. Then, I tried claiming it again, but it won’t claim.

Here is a video of the full light loop. The red blinking is at the 0:58 point of the video.

OK, I solved it. Apparently when you run

particle keys doctor <yourDeviceID> 

your Device ID is case sensitive. I needed all of the letters in the ID to be lower case. I was thinking the ID was Hexadecimal which traditionally has upper case letters.

I originally used the mac terminal command

system_profiler SPUSBDataType

to find the Electron’s ID on the bus, and it gave me all uppercase letters.

Thanks for all the help!

It is supposed to be case insensitive and that issue was reported to Particle a while back - maybe this is a regression or you’ve got an old version of CLI.
What’s your version?
@jvanier can you have a look at CLI for that issue?

I’ll try to locate the previous report.


Update:
It wasn’t exactly for the keys keyword, but for the device add command, but that’s still a bug, since the device ID validity check should be consistent over all commands

@jvanier, should we reopen the old issue or file a new one that stresses the call for consistency across all commands?

BTW, the aleged “fix” in that issue seems rather questionable to me (to say the least of the words that pop to mind)!

And obviously did that internal bug not get filed, since there were several versions since Feb. 2016.