Electron shows up as Photon in DFU mode

My Electron with Firmware version 0.4.8 used to show up is DFU mode as Electron on Windows 7. After updating to version 0.5.2, it now shows up as Photon. When it shows up as photon I can’t run
particle update. I get this message eventhough it blinks yellow? Is this a know issue? How can I get it show Electron in DFU mode?

F:\Particle\TrackerDebug-master\firmware>particle update

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

  3. Release the MODE/SETUP button once the device begins to blink yellow.

Mine shows as Photon too, but I can still update.
Can you try reinstalling the DFU drivers via zadig?

I have used the description and download here to update the device
https://docs.particle.io/guide/tools-and-features/firmware-manager/electron/#connecting-your-device
After the update it’s blinking CYAN but not not yet breathing CYAN. I am trying to get it breate CYAN

I have reinstalled the DFU drivers using Zadig but still it’s not working. After install, I see the device as Photon DFU-mode as shown here

When I run ’ dfu-util -l’, this is what I get

F:>dfu-util -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

And when I now run ‘particle update’, I still get this error although the device blinks YELLOW

F:>particle update

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.
  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.
  3. Release the MODE/SETUP button once the device begins to blink yellow.

What surprises me is that this is a device I got it just last week in DFU mode and updated. I can’t imagine that the issue is because I updated from 0.4.8 to 0.5.2 and also that I now see the device on device manager as Photon instead of as Electron.

I tried on a different computer and it worked. I updated the electron

particle update
particle flash --usb tinker

and I am now to solve my original problem where the simple blinking code example doesn’t run on my electron. I have followed up the exact problem in this thread!


In his case he was adviced to try
particle flash --usb firmware.bin
and this worked for him. I have tried this but it doesn’t work.

So I have set the firmware back again

particle flash --usb tinker
And my electron blinks CYAN. I have been told to first get this BREATHES CYAN and not blinking cyan before continuing. I have tried all possible button combinations; RESET and MODE but the Electron keeps blinking cyan and not breathing. It appears this is the real problem I am having which leads to the fact that I can’t get the simple code execute on the electron.
What can I do to get this device breathe cyan?

Is this zadig screenshot before you hit the Install Driver button?
Since that screenshot does suggest that currently you haven’t got any (hence the “(NONE)”) installed for that device.
You could also try a different USB port and cable.

Is your Electron breathing cyan now or still not?

Can you post a video of your Electron what colors it’s playing from power-up till blinking cyan?

The screen shot was before I hit the install button. This video shows how the electron now blinks after I run

particle flash --usb tinker
I can’t get it breathe CYAN. When I power the device on, it blink about 3 or 4times green and then switched to blinking cyan very fast and the slow and the very fast again. It simply never breathes cyan. I believe that once it breathes cyan, all other issue I am having that user firmware can’t run will be solved

Unfortunately I can’t attached a video here . I get a message that it’s unauthorized. Only JPEG, png and other image formats are allowed

You could upload the video to vimeo or YouTube and embed here or a post public link on e.g. dropbox

BTW, what’s the type of the ublox module on your Electron?

Could you also PM me your device ID, maybe @BDub or @Dave can have a look in the logs.

Link to the video

Here is the my device ID

C:\Users\rlingeh>particle identify

Your device id is 2f00490019513533383
Your IMEI is 353161075672397
Your ICCID is 8934076500002682185
Your system firmware version is 0.5.2

Could you unplug the USB and battery, remove the Electron from the AssetTracker, then reattach the battery and USB and power up the Electron with it just sitting on a non-conductive surface and see if it’s able to get the breathing cyan in that configuration?

I have disconnected the USB, unplugged the battery, separated the Electron from AssetTracker, Connect back the battery and USB but still getting the same effect. It continues fast blinking cyan. I came across this link from Dave

Since I sent my device ID perhaps he may be able to find out.
Simply put “My Electron has never made it to breathing cyan”

Hi @rlingeh,

Hmm, I can confirm I haven’t seen your electron fully connected to the cloud on our end. Try running the “keys doctor” with your device in DFU mode with the CLI if you haven’t already. Also the device id you posted earlier was only a partial id.

#put your device in listening mode (remove the sim card)
particle identify

#put the sim card back in, restart into DFU mode
particle keys doctor YOUR_DEVICE_ID

Also, make sure you’re using the latest drivers for windows ( https://s3.amazonaws.com/spark-website/Particle.zip ). The old one might not have IDs for the Electron, and might only have the photon.

Thanks,
David

1 Like

Hi @Dave,
I have followed your instructions here to generate a new public key for the device. But still it’s not breathing CYAN as you will see in the attached video.

C:\Users\rlingeh>particle keys doctor 2f0049001951353338363036
Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
New Key Created!
Found DFU device 2b04:d00a
Found DFU device 2b04:d00a
Saved!
checking file 2f0049001951353338363036_ec_new.der
spawning dfu-util -d 2b04:d00a -a 1 -i 0 -s 3106:leave -D 2f0049001951353338363036_ec_new.der
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device…
ID 2b04:d00a
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000c22, size = 122
Download [=========================] 100% 122 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Saved!
attempting to add a new public key for device 2f0049001951353338363036
submitting public key succeeded!
Okay! New keys in place, your device should restart.

Here the video

So at this stage I don’t know what to do next to get it breathe CYAN. We actually ordered 2 of these devices but have not yet succeeded to get one breathe cyan and I am wondering what we are doing. It appears we are doing everything totally wrong but I can’t figure out why

Hi @rlingeh,

Hmm. You’re using the sim cards that came with those Electrons, and you activated them yes? Can you send us a support ticket using https://support.particle.io ?

Thanks!
David

Yes, I am using the SIM card that came with the device. I have already activated the device. We got the devices through a Vendor in Germany. Don’t know if this has any effect. We later got the PROMO codes from particle.

Okay, I will send a mail to support

@rlingeh would you please grab a backup image of your electrons with the following command. You just need to have your Electron in DFU mode, and run (note the replace_with_device_id):

dfu-util -d 2b04:d00a -a 0 -s 0x8000000:0x100000 -U electron_backup_replace_with_device_id.bin

This should create a 1MB file. Please PM me the files… you can just email them to me as well if that’s easier. brett (at) particle * io.


Then after backing up, please try reprogramming the Server Public Key by having the device in DFU mode again and running this command with the CLI:

particle keys server

Then reset the device and see how it goes. Thanks!

Now it works!!! Again this is strange. The electron now breathes CYAN. I have been struggling with this for over 2 weeks.
After running

particle keys server

Everything worked. I was recommended to try this: particle keys doctor YOUR_DEVICE_ID but it failed. It’s look a series of trials and errors. I do hope that we will not have the same problem with the second device we ordered.

@BDub I already sent you an email with the generated file. I think you may ignore the mail

Thanks alot: