Electron not connecting via USB

Hi all,

I have an electron that is not connecting via USB. When running particle setup, I receive a message “No devices detected via USB”. I have tried multiple USB ports and receive the same message each time.
This electron has worked in the past, but has not been used in a few months. I am new to particle devices and would appreciate any information and suggestions. Feel free to ask me any questions that may help specify the error.

Thanks in advance!

It’s funny - just today I helped another guy with a very similar question - have you tried searching the forum first?

But to actually answer you may need to provide info about your host OS, what colour code your RGB LED displays and whether Serial or DFU connection fails.

1 Like

I am using a PC with Windows 10, 64-bit OS. The RGB LED is flashing green. I hold down mode until the LED flashes blue before attempting to connect. As far as I know, both Serial and DFU connections fail.

Do you get the typical Windows “attached device” sound when you plug in your Electron?
Does it appear in Device Manager?
In what category?

There is no “attached device” sound, and it does not appear in device manager.
However, the electron is receiving power via USB connection.

Try some different USB cable(s) then.

1 Like

I’ve wasted countless minutes troubleshooting things only to find that the USB cable was bad.


I have the same issue - looking for a third cable now…

3rd cable did it… :crazy_face:

1 Like