Unknown USB Device - can't connect via usb

Hello,

I’ve been using an electron for a few days and was able to set it up and communicate with it over USB successfully. Then something happened (who knows??), and now my computer does not recognize the serial connection. In the device manager, it sees “Unknown USB Device (Device Descriptor Request Failed)”. Other borrowed particles DO work on my computer, other cables work, but electron does NOT work on other computers, so it seems to be an issue with the electron. I’ve tried to uninstall and reinstall the drivers. I updated the firmware very recent, though right now as I try to do a firmware update ota, I get “flash device failed”. Looking for some help to get back connected by USB, thanks!

i’d begin by doing a check on which modes i can put the device in via the 2 buttons.

I’m having the same issue with my Electron right now. Hard not to throw it against the wall. I originally turned it on days ago to diagnose why it was intermittently not coming out of sleep states. Then the GPS stopped reading (using external antenna, was known to work really well for a couple weeks, even in my basement, but somehow the red light is flashing to say it does have a connection). Now the CLI can’t find any serial port to read. I’m sure I’m doing something wrong, but damn, it was all working and it’s all flaked out. I haven’t used the USB on this laptop to do anything besides connect to the Electron either. Didn’t change any driver settings. Back tracing my steps isn’t fixing the issues either. I have multiple photons, love the Particle interface, but this product is really frustrating. Before I was blocked with these newer issues it seemed like simply plugging in to charge over USB was breaking the sleep mode and locking it in there.

I know none of this is productive and I’ve asked no questions. Just need to vent. Didn’t want to start a new thread for that.

No you haven’t, but you left a lot open :wink:

What host OS?
What device OS version?
Have you tried Safe Mode?
Have you tried Listening Mode?
Have you tried DFU Mode?
Have you tried a/some different USB cable(s)?
Have you tried a different USB port?

For Windows:
Do you hear the device connected sound when plugging in the device?
Do you see the device in Device Manager?

1 Like