COM port issues with Electron

I am brand new to particle and the Electron. I’ve been flashing over cellular with no issues and decided to start working with the USB serial connection. I am running W10 and my Electron firmware is 0.5.4. When I plug the USB cable into any port (USB 2.0, 3.0) on two different machines, there is no plug-and-play detection of the Electron. I tried adding “legacy hardware” but after installation it says there is a problem and the “device cannot start (Code 10)” in DevMgr. Its shows an Electron in the device list but it has a yellow caution symbol:


When I use “particle serial list” on the CLI, it says it finds one device: “COM3 - Core”, but when I try to monitor serial from devices, I get an error about not being able to open COM3:


It’s like the Electron is not acting like a USB connection. I’ve read few posts but I’m not sure any of them resolve this issue. Any thoughts or suggestions?

I’m not too familiar with the CLI interface, what type of interaction are you looking for? I just ran into an issue today. In the Electron documentation they suggest using Putty, . When you connect in the session, make sure you choose “Serial” as the connection type.

Have you tried this route yet?

Have a look over here; my esteemed colleague Rick has written up detailed information on Win10 driver issues.

BTW re: PuTTY – I prefer TeraTerm (Windows only) because it will automatically reconnect to a device after a restart.

I tried another shorter USB cable and it works fine. Must have been a bad cable. Thanks for the responses!

Ah man I forgot to ask you about the cable. I wonder if the one you tried is a power-only one. Those should be outlawed.

I think it is. I borrowed it from a phone charger since it was long. Lesson learned!