Electron G350 connectivity (flash sequence)

@BDub1 or maybe @BDub ?
I live in Australia and have a G2 G350 Electron (Kickstarter version) exhibiting the same symptoms as @laughlinez and others.
I have tried all the steps as described above but NOT touched the SIM card yet.

What I have noticed is that near some towers I get the fast cyan/red/slower cyan pattern but outside my home about 300m from a Telstra tower I only ever get green blinking (with occasional drop back to blue blinking). When green blinking it doesn’t seem to use any data but when cyan it does.

Do you want me to save any information or take photos before I inspect the SIM card connector?

Not sure which time zone you are in but I will only be awake for an hour and I will resume tomorrow my time. How does one raise a support ticket?

@BDub @laughlinez @wdj
Breathing cyan! I simply pulled it out of the breadboard - didn’t touch the SIM card connector.

I have been able to claim it.
Now to test it at home where I only ever got blinking green (I’m currently near a tower that it did respond to with cyan blinking before).

@wdj - I am going to play with some pull-ups or caps to see if they can reduce the apparent noise effect.

Yep it breathes fine at home outside… but not inside my office away from the window. It took a while blinking green and then finally started breathing cyan. It is still out of it’s breadboard, will have a go at some fiddling with pull-ups/downs or caps? Hmmm need to read the specs again.
Anyone got any comments about what might be best and which pins might be most likely to be causing the problem?

Hence the statement :wink:

Hi There,
can confirm that here in London - removing my 2G electron from the breadboard did temporarily fix the problem of fast flashing cyan and then short burst of red. It was breathing cyan and connecting to the cloud properly. But then maybe 10 minutes later it lost the connection and cycling the fast cyan blinking with red burst again.

So tried then pressing down on the SIM and reset and it breathes cyan again. Looks like a physical issue to me.

Hi All,

Whats the status on this? I have had my electron running fine for a day or two and then it starts blinking green… I have tried two different SIM cards with the same result. Works for a while and then stops. Taking the SIM out and sliding it back in seems to solve the problem for a short time and then it comes back.

My take is that the SIM holder is poorly designed and allows the card to bend itself outward eventually loosing good contact.

Bummer when we spend loads of time trying to make our App bullet proof only to have failures like this, for the moment its a no go!

Has their been any official word on this from the Particle team ?


Hey there @ssozonoff – if you’d be willing to capture the device logs on the device, we can tell you the exact reason that the SIM is blinking green. Unfortunately, even within this single thread the contributing causes have been everything from issues activating the SIM to no reception to a damaged SIM connector to the wrong hardware, so it’s impossible for us to diagnose the root cause based on the symptom alone.

The best route forward is to email our support team through our Support Portal at support.particle.io. You should get a response within one business day or so–please let me know if you don’t!

Happy to do so however I use a 3rd Party APN. Looks like I am going to have to install a local toolchain and everything to get this to you ?

Does the electron-troubleshooting binary exist doe 0.5.2 ?


You should be able to flash lower version app firmware to higher version systems.

The instructions for the Electron troubleshooting app are [in this document] (https://docs.google.com/document/d/1U_Wzy2SPRC3hZnKtw8d6QN2Tm8Q7QwtEbSUAeTkO3bk/edit).

The 0.5.1 binary linked to from that page can be used on 0.5.2.

Also, you don’t need to build your own electron troubleshooting app binary for use with a 3rd party SIM. You can set the 3rd party SIM APN information using the D command at runtime.

Thanks but the troubleshooting App does not really help since my issue is random and non repeatable.

It works perfect for a random amount of time and then all of a sudden I get a blinking green LED. Usually if I power down everything and slide the SIM out and back in again then it works again for a Random amount of time. Could be days could be hours…

I would need to run my App with the 3rd Party APN and DEBUGING enabled in the firmware…

If you have a Windows machine, we’ve created a CLI installer for Windows that makes this process very simple. We don’t have installers for Mac or Linux yet, but it’s much easier to install on those platforms.


Hi @ScruffR So what do you propose, how can we keep the electron breathing cyan while connected to breadboard? I got my electron today and it connects fine to cloud until I mount it on breadboard. Thanks

I can’t really tell since I’ve never really seen that with any of my Electrons in any of my breadboards, so I’m just theorizing about possible causes :blush:
Are you using the breadboard that came with the Electron?
How about mounting it on a different one or different locations on it?
What colors does it play?

I am using the one that comes with electron. It blinks quickly cyan and then red repeatedly. I tried changing breadboards but no change in the behavior

Another thing I noticed, If I pull electron from breadboard and wait for it to breath cyan and then put it back on the breadboard, it remains connected to cloud. However, if I then go on and try to call a function on electron from cloud it disconnects right away. I was able to reproduce this behavior 100%. It happens with tinker app and firmware as well. The moment I send a digitalWrite from tinker the electron board starts blinking rapidly cyan and then red.

There is another thread where the issue resembles more to mine and I have added more details there.