Electron G350 connectivity (flash sequence)

@BDub, others

I now have my (Stock) electron breathing cyan - just plugged it in this morning and it went straight from green (10secs) to flashing cyan (10secs) to breathing cyan.
It was in same place/location at yesterday with noting done to it what so ever.

My (Flashed) Electron with the doctor keys is still doing the rapid cyan/ red cycle, so it have been unplugged until i can talk to support next week.

Bingo!

I took another look at the SIM card connector on my (Flashed) Electron 2G. Although the back 3 pins seemed to make contact (can see a trace), they actually look to lift slightly as the card is inserted, the effect was a very slightly raised back edge when fully inserted.
I lifted the back legs a few “thou” and reinserted my card.
After a very quick green/cyan cycle this one is also breathing Cyan.

So - i guess the SIM holders are a weak spot for some devices.

This means that the flashing cyan/red could also mean a SIM problem?

Final post for today.

“Higgs” and “Boson” are now alive in my dashboard.

“chameleon” will be unboxed shortly - i’ll be sure to check the SIM connector.

Ditto! My G350 is also now working after carefully removing the SIM card and even more carefully raising each of the six SIM contact points about 1mm and then reinserting the SIM. So, looks like this was actually down to a somewhat initial dodgy SIM connection…

Wow, that is unexpected actually. Thank you @laughlinez for being persistent :slight_smile: I’ll be looking into this in more detail to see if I can replicate this and find a way to keep the Electron blinking blue for this SIM connection issue. When you say “back edge” do you mean the side of the SIM closest to the edge of the PCB?

@BDub,

Yes, the three sprung pins at the short edge of the PCB.
The 3 closest the processor (on inside of PCB) I did not need to touch.

On the ones I “lifted”, I can see that they only just make contact even when the SIM is fully pushed up to the stop.

It could be that in original position there was not enough tension to make a full electrical contact. Lifting them just made them “bite” a little more into the SIM contact area. I think anyone who does this needs to be very careful because these pins only overlap the SIM by about 3mm and it would be easy to damage them.

I just used a tiny 3-finger piece of parchment paper to selectively insulate every combination of the 3 outer pins, and 3 inner pins separately. I did not try combinations of inner and outer. Each resulted in the Electron blinking blue, except for one case which ended in breathing cyan. I insulated the inner middle pin, which connects power to the VPP of the SIM. This is only necessary for updating the contents of the SIM like changing the PIN. This explains why insulating it had no effect.

It will be more difficult to test the other combinations, but doable. However looking at the connections, I can hardly see why a bad connection on any of the pins will allow it to work at all.

If anyone else has this problem, I’d love to see what your device logs look like before you attempt to fix it with the SIM holder. Please contact me directly so I can give you instructions on how to enable logging on your device.

VCC (power)
VPP (programming power)
GND (ground)
CLK (clock)
I/O (data)
RST (reset)

A first step before bending the pins of the SIM holder might be to slide the SIM in and out a few times to attempt to clear away any debris or oxidation that might be on the SIM contacts.

@BDub,

I do agree its a shame we had no “control” in place whilst doing this messing about.

My reasoning for doing this came about as follows:

I removed my SIM to try to clean it a little.
I put it back in and all i got was 4 white breaths and into LISTEN, no green flashed at all.
(I thought this was definitely a SIM issue now).
I then held the sim tighter against the holder with my finger whilst I reset.
I got green flashes, to released my finger pressure, and back to white breathing - > blue.
At that point i figured it was definitely a SIM connectivity issue.
That was when I put more tension on the springs (just the back ones) and reinserted the SIM.
At this point everything sprang into life.

A little update of things noted during today:
Both electrons lost data connection around 13pm uk time. just flashing green.
I unplugged batterys, I went to “have a life” for a few hours.
I came back at about 4pm UK time, plugged it and was away again with cyan breathing, all seems fine atm.

My observations about that is simply that my cell tower was either busy or reduced output, and my devices lost connection. This raises a question I’d like to ask, about antenna (impovements) - but i will post this elsewhere.

So - its either very coincidental with other events, or the SIM tweaks did have a positive effect at getting that first connection going.

Do you want logs from mine before I try troubleshooting the sim contacts?

Since you opened a Ticket, I’ll reply there :wink: Thanks!

All,

I just thought i’d update you on things my end.

I was contacted by Particle support yesterday (email). With an approach to diagnostics.

I plugged first electron (stock), and it quickly connected and has been breathing cyan ever since.
So - i attempted to connect second (this one had now been tweaked to have a giffgaff SIM with a 5UKP gigaplan and new firmware). Low and behold this one connected also - even quicker than first.

Both were left on overnight, but the giffgaff one had a dead battery this morning. The first electron is still breathing cyan. I put the second on charge and it connected within about 15secs, so its also connected for a second time.

In short - both are connected. I needed to do nothing but connect since particle contacted me, so I have not needed to run through any of the diagnostics.

How is everyone else doing with UK 2G 350’s?

PS: I have a third electon, but i am not going to connect it for a few days - will be interesting to see how “it” fairs with connectivity?

Too good to be true…

After a good solid 14+hrs (8pm -> 10am) , they are now flashing green (and sometimes cyan) again.

I feel surer than ever that this is a both signal+priority based (for my area at least).
(We have proven already that they make a connection (breathing cyan) without changing anything my end)

I am going to relocate one of these closer to the city to see if that helps.

Here is what I do know:
Connections seem to work better at specific times. Evening 9pm->11pm+ seem fine, as does all the way through the evening into morning up until about 9am+ when connectivity ALWAYS seems to be problematic.

I will also now start to follow the diagnostics process to attempt to identify the weak spot.

Hey all,
I’ve found that my electron is unreliable when plugged into a breadboard, as soon as I unplug it, and hit reset, it connects within seconds. If it’s plugged into the breadboard it mostly does not connect. Have tried two different breadboards.
It seems there’s maybe some RFI/EMC problem?

1 Like

I have my Electron running for two days with no problems at all. It is sitting on the breadboard, happily breathing Cyan and is shown in the dashboard.

One thing which is a bit weird is that the battery charge goes down all the time without the charger recharging it, although it is only about 83%. When I disconnect it from USB and replug it again, the red light will go on for a while. But it will go out before reaching 100%. So there seems to be either a measurement error or the charging does not work correctly, or I don’t understand how the charging should work.

They set the charging voltage low to be on the safe size for batteries in temps above 45C.

I also only see the SOC go up to about 83%. The charging voltage is set to 4.11v I’m pretty sure. It’ needs to be changed to 4.20V at least for the fuel gauge to go up to 100%.

There is code to do this but I have not attempted to change it yet.

I started a thread here about this: Changing Battery Charging Settings - Electron

2 Likes

@RWB, Thanks for the information, good to know!

I’ve found that my electron is unreliable when plugged into a breadboard, as soon as I unplug it, and hit reset, it connects within seconds.

As odd as this sounds it solved the problem for one of my electrons, haven’d tried it with any others yet.

1 Like

Just a background on this.
Breadboards add some extra capacitance which might in combination with high frequency and common inductance of your setup lead to noise.

2 Likes

@BDub perhaps we need to be pulling up unused GPIO pins to prevent them from floating and picking up stray capacitance?

1 Like