Electron Breathing Magenta?

Hey all,

I loaded the following trivial sketch (compiled in the cloud, loaded over USB):

void setup(void){
  Serial.begin(115200);
  Serial.println("Hello World!");
}

void loop(void){
  Serial.println(millis());
  delay(500);
}

particle --version
1.18.0

particle flash --serial electron_firmware_1481042725289.bin
! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE
sending file: electron_firmware_1481042725289.bin

Flash success!

… and when I reset my Electron it goes breathing white, blinking green, flashing cyan, breathing magenta. I haven’t found any description of breathing Magenta in the docs. If I open /dev/ttyACM0 in PuTTY @ 1115200, I get no output. Where am I going wrong here?

Now I’m getting messages in the Web IDE like this:

You’re trying to flash your app for system firmware version 0.6.0 but your currently selected device, StableSense-Test is running system firmware version 0.4.9.

Flashing this app without first updating the system firmware will put the device in safe mode. Please change the system firmware compile target for your firmware to 0.4.9 or update the system firmware on your Electron before flashing this app.

Guess I shoudl try and update the system firmware… now to find out how to do that.

https://docs.particle.io/guide/tools-and-features/firmware-manager/electron/

The Firmware Manager is available for Windows and OS X.

< groan /> Guess I’m restarting into Windows.

@vicatcu if you have CLI and DFU installed, you can flash directly using that:

https://docs.particle.io/reference/firmware/photon/?fw_ver=0.6.0&cli_ver=1.18.0&electron_parts=3#programming-and-debugging-notes

In Windows 10, I’m getting this when I run Firmware Manager for Windows (whether or not I right-click and Run as Administrator)…

… and I have a solid magenta light now …

@peekay123 I got the system update to work using DFU-mode. I feel legendary after doing that many backflips :smile:

2 Likes

And just to close the loop here, once I got the System Firmware updated and selected that in the Devices section of the Cloud IDE, and rebuilt it, the trivial program worked and I could see information in the Serial Monitor.

2 Likes