Breathing magenta when I try to flash with Particle Dev

I have a program that worked fine a couple weeks ago on my Photon, but now every time I try to compile and flash it, the Photon simply appears to go into Safe mode (breathing magenta). Am I making a mistake using Particle Dev? Do I need to move (back) to the online IDE?

I am able to flash Tinker and have it work fine.

I’ve wasted tons of time on this, refreshed 4.6 via DFU in case I compromised an update when getting a bit impatient and power cycling a magenta breathing Photon.

Is it possible my program requires something that needs an update and that’s why it breathes magenta?

There’s a ton of helpful information on this forum, but there is a TON of information that’s a bit hard to get through.

I had this same thing happen on another Photon, but somehow managed to get through it via “particle update”.

So…I as one post suggested, I created a very simple program on the web IDE and made sure 0.4.7 was selected as the firmware. This seems to have corrected the problem. Did I fix it “correctly” or merely stumble onto a fix?

I have ordered several additional Photons and I suspect I’ll have issues with them, too, and I simply want to avoid today’s painful experience.


When you say

This suggests that this was the problem, since Dev and CLI always build against the latest versions, which currently is 0.4.7.
Having an application firmware targeted for 0.4.7 and running a system firmware with an incompatible version must fail.

There are alternative ways to update the system firmware are
particle update or the DFU way you tried for 0.4.6 but of course using the correct binaries.