Does Particle Device Doctor Work for Argon?

Hello I am using this particle argon for a class project and recently it would only light cyan. It would not allow me to flash and it will not let me put it in safe mode it blinks green and then back to cyan. I tried to used the device doctor but am getting this message.

The Doctor didn’t complete successfully. Error writing firmware: file does not exist and no known app found. tried: doctor

Please visit our community forums for help with this error:
https://community.particle.io/

Could someone guide me to how I can reset my argon to get it working again? I am new to coding and working with these devices.

Hi,
From what I gather, “The Doctor” does not work for Gen 3 devices. Try this:

Disconnect any external circuitry from the Argon.
Connect a USB cable from your computer to the device.
Enter DFU mode manually. Here is a link for DFU mode:

https://docs.particle.io/tutorials/device-os/led/argon/#dfu-mode-device-firmware-upgrade-

Using CLI, try:

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

You might check out Tinker and see if it is working properly (perhaps blink On/Off the built in LED). Then see if you can access the device normally by flashing your firmware.