Deleting a Library

Im trying to delete a library I had imported from my Git account; No amount of DELETE LIBRARY button click and acceptance is working. Any suggestions as to whats next on it.

1 Like

Is the use counter of the lib down to 0?
If there is an app using this library, you won’t be able to delete it - otherwise you’d break that app.

okay . I tried several browsers, operating systems and internet connections. Its not in use in a App.

Have you had the lib published or is it only a private lib?
If it’s public, which one is it?

its a private lib ; its interesting that it says its validatd and can be imported but then reports its not valid as well; hence I tried to delete it. Cant import it. cant get it to see that the libraries have the items it seeks as per library spec.

Do you by any chance use another branch than master to import?
I’ve had the weirdest results when I tried to import a develop branch.
Have you got a link to your repo to have a look at it?

In this case there is only one Branch , the Master Branch . the Repo :

I’m surprised that this repo was at any stage seen as valid to import.
You should not have an .ino file directly inside firmware. You should rather have that inside an examples folder.
And your .h and .cpp files (these actually are supposed to be the library files) should not be empty.

1 Like

would that impact being able to delete the library .

If it wasn’t actually imported properly ability to delete might in deed be impaired.
Maybe @suda can have a look on the Build servers.

it would be good if he could it sort of holds up the whole experience here; I’ll go through and see if I can mung the files enough to blag a validation and try a delete in the meantime.

actually never mind it appears the Library has gone from my IDE page . I guess heading out and doing other things over the weekend has helped. now to get back to it.