Core keeps flashing green

I’ve just rested my core for a couple of days, but now I cant connect my core to the network, it just keeps on flashing green. I’ve tried multiple resets and searched the community on how but still no work. Will I do the patch upgrade?

You can try doing so :wink:

I’m trying to install the spark-cli but this error happens all the time. I’ve already installed node.js

you can try sudo npm install -g spark-cli

Also it looks like you are on Yosemite so you will need to install/activate xcode.

yup it’s already done. still no work

@Moors7 Can you help me to connect my core, I’ve created this thread a while ago but I only got few replies, so far what I’ve done is:

  1. tried multiple factory resets
  2. changed or played with the settings of my router

*** I’m thinking of updating the firmware of the core but I always got an error installing the spark-cli through node.js for both mac and windows.

*** do you think I need to update the firmware, my core does accepts the credentials but does not able to connect through the internet.


If the error you’re getting is the one from the screenshot above, then you should try to install Xcode properly. It needs the command line tools to be able to work, which you obviously haven’t installed.
I don’t own an Apple computer, so I’m not sure if I can be of much help in that regard. You should try the tutorials section for help on setting up the CLI, there are a few guides available.
On my windows computer I managed to successfully install the CLI by following the awesome tutorial provided by @kennethlimcp

Once you’ve got that running smoothly, we can start looking into reflashing your Core, and applying possible patches.

Have you perhaps tried a different access point already, like a mobile hotspot, or a different wifi network? Would be nice to rule out network issues.

Maybe I should also point out that if you can get DFU-util installed you can still flash over usb :slight_smile:

I’ve also tried installing CLI on Windows but still no luck at all. Can you please give me a step by step, I’m confused if I’m gonna install dfu-util or others.

I’m now trying to install cli on windows, but why is it that when im installing the dfu-driver using zidag the error says FAILED (OPERATION TIMED OUT)

You do realise there a several for the different operating systems to be found in the tutorial section? I followed them exactly as they were, and the CLI has been working without problems ever since.