Claiming an E-Series module

electron
Tags: #<Tag:0x00007f1ca17a4ee0>

#1

Hi,

So I recently got a E-Series module and have it up and running on my PCB.

I’m trying to claim the device using,

https://setup.particle.io/

But I’m unable to do this because it asks for the Serial Number(which doesn’t exist since it’s a module, not the E-Series kit).

The Device ID I can read from the serial port isn’t accepted by the portal. The E-series is running v1.0.1 firmware.

Note that I was able to claim the eSIM via the ICCID number.

Any steps suggested to claim this module?

Thanks!


#2

Hey there!

Great question, thanks for posting.

As the E series and Electron are near identical in nature (they run the same device OS, for instance ), much of their functionality is interchangeable.

If you ever had difficulty accessing the serial number for your device, one neat little trick you can use as a workaround is to actually go through the setup method for the Electron when setting up your E Series.

You mentioned you were able to grab the device ID from the serial. I assume this was from the particle identify command. This also should have provided you with the ICCID you can use for setup on the Electron setup method.

Go ahead and give the Electron setup method a go and report back here if you have any questions or concerns. I’ll be happy to assist. :slight_smile:


#3

Depending on the stock device OS of your module you may also get some more information when talking to the device in Listening Mode via a USB Serial Terminal program and send the i command.


#4

Hah! The electron method worked.

I’d suggest an update to your E-series claim step, that wasn’t really intuitive :slight_smile:

Device is up and running now, cheers.


#5

With the serial number in hand, the E series setup should be a lot simpler. We store a copy of the device ID and ICCID on our end, so we are able to associate it with that.

Without the serial number–it is a bit less intuitive of a setup, I admit. :sweat_smile:I’ll see what we can do to resolve that from a docs perspective.

Thanks for the update to let us know it worked!