Can't connect to Blynk after upgrading to 0.70

Updated Photon from 0.63 to 0.70.
After the OTA upgrade I was unable to connect to Blynk.
Tried downgrading back to 0.63 but still unable to connect.
Anybody else facing same issue?

Update to my problem. I am using a Photon/P0 and firmware currently installed is 0.6.2 with Tinker after using Windows CLI for the first time.
I don’t know how to proceed with updating firmware. Tried OTA to upload code and Upgrade to 0.6.3 or 0.7.0 but refuses to upload anything new. Still stuck on 0.6.2 and Tinker.
I don’t know what commands to use with cli. Any assistance please?

You can use particle update to update your device in DFU mode, but you need to make sure you’ve got the most recent version CLI (particle --version should return 1.29.0 for 0.7.0).

What is the correct procedure to update the cli ?
My version is 1.24.1
i run the update-cli and it returns Updating CLI… Timed out while updating

That depends how you previously installed CLI.
Assuming you are on Windows (due to the use of update-cli), if you can’t remember whether you used the Windows Installer or npm you may want to uninstall CLI via

npm uninstall -g particle-cli

After that try running particle update-cli again. If that fails (e.g. due to “unkonwn command”) you can reinstall CLI via this
(make sure to tick all the check boxes to be on the safe side)

I believe this is why it won’t update

Could it be that your antivirus or firewall is interfering or your network is flaky?

Will check again…

It refuses to update. I end with version 1.24.1 every time.
I also tried with Particle Firmware Manager… but in the docs, the link to download is 0.6.0