How do I go back to firmware 0.7.0

I recently updated to version 0.8.0 however I’m having issues with Tinker to the point I cannot even get the example ‘Web Connected LED’ to work and the app always seems to tell me my Photon is in flash mode when its not so I cant use the app.

I suspect it may be due to a few bugs in 0.8.0 so I want to return to 0.7.0 however the using the cloud IDE it isn’t changing the firmware despite what I pick, so I even tried the windows exe that updates the Photon to version 0.6.0, it said successful but when I logged back on the IDE cloud it said the Photon was using version 0.8.0 still.

Anyone know a solution please?

You can’t downgrade the Device OS via Web IDE, since any application targeted to a lower system version should run on any higher (or equal) version Device OS.

You can use CLI to go to the latest default version via

particle update

but make sure, the application on the device is not triggering an auto-update again once 0.7.0 is flashed back on the device.

I’m trying to downgrade my photon through the CLI with particle update and getting the following error:

Error: Command failed: dfu-util -d 2b04:d006 -a 0 -s 0x080A0000:131072 -U user_firmware_backup.bin
File exists: Cannot open file user_firmware_backup.bin for writing

Not quite sure where I’m going wrong, upgraded the CLI but I’m still getting the same error.

Make sure you’re in a writable directory when you issue the particle update command. For example, if you were in C:\Windows I think you might get that error.


Also what version CLI are you using.
The Device OS version you’ll get with particle update depends on the version of CLI.
The most recent version that will give you 0.7.0 is 1.32.4

Should have realized this was the issue, but thanks for reminding me of the obvious. I’m confident that this worked but can’t confirm as I can’t seem to reset the WiFi network on my photon at this time.

Edit: Confirming that the above was correct.