Unable to downgrade Photons


#1

I’m experiencing an issue with downgrading my photons from within the Web IDE. I have tried the following:

Upgrade to 0.7.0. Once upgraded I attempted to downgrade to 0.6.3, it looks like it works, IDE returns Ready, but firmware is not downgraded.

Upgraded from 0.7.0 to 0.8.0 pre-release, same deal, can’t downgrade back to 0.7.0 - its a one way street.

Anyone else experiencing this or have a solution other than CLI?


#2

I will probably be corrected but that has been my experience - i.e. 0.7.0 to 0.6.3 is only possible by using CLI to force install the Device OS. If you have products then the console will not downgrade from 0.7.0 to 0.6.3. Ideally, you will use 0.8.0-RC.12 since it is vastly better than 0.6.3 and 0.7.0.


#3

The target system version selector in the IDEs (and --version in the Particle CLI) specifies the minimum target system version that your user firmware can use. It will never cause the system firmware to be downgraded.

Downgrades can be done using the Particle CLI (or API) using OTA or USB but there are very specific version and ordering restrictions, depending on the method used. There’s more information at the end of this document:


#4

Hi Joevitale,

I’d take Armor’s advice and go to the full 0.8.0-RC.12 before trying to move back to 0.6.3.

Firstly it is easyer to upgrade over the air… I mean really easy. I had an odd issue moving up from 0.6.3 to 0.7.0 and checking out the docs it was very possible to down grade, but over USB and using CLI. Its always a tense moment flashing firmware, and whilst I’ve done it a few times, its not exactly the sort of thing you sit down with a tube of Pringles to do as entertainment… so I went to 0.8.0-RC 12 in a dismissive hope, and it sorted my issue… which was an odd thing running neopixels of all things… but under f/w 0.7.0 the photon froze up breathing green after a few hours… but pushing through to 0.8.xxx solved it… Odd, but hey…

Oh, and flashing over usb means you can go straight to the f/w you want in one move…

Liam