Firmware 0.70 rc4 upgrade downgrade wifi problems

I tried updating my Particle Photon in the Particle build be setting System firmware target to 0.7.0-rc4 and Flashing my code.

It seems to Flash, blinks pink etc. however after that it won’t connect anymore to WiFi (fast blinking green) or the Cloud.

So I’ve connected my device to my computer, put it in DFU mode and tried updating the firmware with particle update. I suppose that command will update it back to the latest release 0.6.3.

Well the update succeeds indeed and the device connects to the Cloud (light blue fade). However it seems that it directly receives a firmware update from the cloud again and starts again updating the firmware (blinking pink).

So long story short, I’m kind of stuck in some loop.

I tried also setting up the device again (dark blue slow blink), but that didn’t help either.

After that I tried to setup the device again with another Particle account (both through the app, and through

Still rapidly blinking green. Of course I checked, checked, checked double checked my wifi password and wifi connection.

Any clues or idea’s are welcome.

(I noticed stuck on green blinking with more Photons recently, also in a student project. However I couldn’t repeat their steps).

In the end I succeeded to get the control back by using the third party po-util tool.

So I connected the Photon in DFU mode and I ran: po photon upgrade

It takes a while (it download three times something to the Photon), but after that I had my cloud connection back (and it was linked to the last account on which I’ve tried to claim the device).

Still I’m curious what is going on, because it seems kind of buggy behaviour and I was lucky enough to be aware of a tool like po-util.

Just for completeness. With po-util the firmware was updated to 0.6.2.

I could succesfully update it to 0.6.3 by uploading the blinking a led sketch.

So I think I stay with the 0.6x releases for now (however I really waiting on 0.7.0 I hope it will be released soon).