Cannot locate a photon via Set up a Photon - Android 6.0.1 on Note 4


as stated in topic title; the particle app is failing to locate a photon via Set up a Photon - Android 6.0.1 on Note 4
Steps to duplicate:

  1. update android to 6.0.1 (Note 4)
  2. tap on + icon
  3. tap Set up a Photon
  4. tap READY
  5. No Photon devices found - at all… ever

This is the same for both latest and previous versions of the app (I updated it to see if fixed etc). Photons found fine on other devices (Note 4) with previous versions of android. Also found fine on nexus 7 with 6.0.1

any ideas?

1 Like

Is it your phone scanning for 5Ghz network?

Can you see it as a WiFi access point in your WiFi SSID list?

Is the Photon blinking blue?

Hi yes it can be seen via Settings > Wi-Fi just not in the particle application as detailed above. I am not sure what you mean with the 1st point? so at a guess have tried with Smart network switch both off and on. Yes its flashing fine; this is the first time I have had such an issue with this device. It can be seen concurrently via 2 other devices.

All was fine until I ran the Android update.

Not sure if @jensck has come feedback?

@dyadica What’s the name of the device as it shows up in the Wi-Fi settings screen?

Hi the photons have now started to appear within the app however connection always fails (on my note 4 only). In both instances (app and WiFi) a board appears something like Photon-ETGY etc

thanks d

Ok if I click connect and then connect via settings and return to the app; the app then continues onto the Select WiFi page and I can complete the setup?

Are you asking if that should work, or are you telling me that it does work, but with a (very understandably) confused tone? :slight_smile:

lol yes the latter :smile:

I have just tried it again with a brand new photon out the box and the same thing. It errors if I try to connect via the app but if I start the connection and switch to settings and then connect there it works. I have to also accept a internet may not be available popup and as soon as I do i get kicked back to the app and the select WiFi screen.

Haha, OK cool, just making sure.

That seems to align with what some others are saying. I don’t think I’ve seen this problem, but plenty of others seem to be now, so I’m going to try to get my hands on a Samsung device to test with again, and see if I can get any information out of my contact at Google.

Out of curiosity, do you own a Chromecast? If so, if you do a factory reset on it are you still able to set it up with your phone through the Google Cast app? I ask because they use the same approach for setup as we do with the Photon. It would be interesting to know if even Google can get this right!

Phew its good to know I am not the only one. We have a few at work so I will grab one give it a go and get back to you; hopefully over the weekend.

Thanks d

Excellent, thanks!

Hi, I just completed a 2.5 day workshop including working with a Photon, i.e., I am new at this!. I am having the same (very similar?) problem. Note that I did post on the forum an hour ago and then found this thread. I can not get my Galaxy 6 to find the Photon, either at the workshop or at home. The instructors used their phones to get my Photon online and I was able to write programs and flash them. But now I’m at home, it is flashing blue (listening mode), but my phone does not find it. I have also tried to get it online via USB. Tera Term did not work, neither did Real Term. Termite at least allowed me to enter the “particle serial wifi” and I got some response but it did not ask for my SSID or Key. I certainly would appreciate any help! Thanks, Earl

I am facing a similar issue, but the difference is, from my note 4 Wifi settings, I am able to connect to the SoftAP without issues. But coming back to the app still doesn’t list it, or allow to move on to setting up my Photon.

Additionally, this past weekend, I setup my Chromecast Audio with minimal problems, although I did have to disable “smart switching” feature in the Note 4 Wifi settings. After that, things went smoothly and I got my Chromecast Audio up and running.

Has anyone figured out what is going on here? I’m aware that CLI interface can be used to get the Photon setup. I’ve already done this, but I’d like to use the Android App to make the customer interface easier.


Is there any update on this? I had the same issue with Android 6.0.1 and Nexus 5. I needed to borrow someones iphone and then it worked.

doesn’t seem like it, this has been an ongoing problem with first android and now iOS as well. Particle for some reason wont devote resources to fixing the apps. I find it varies as well, some new photons i have ordered work fine, older ones i have cant be seen at all on the app, save for the odd one. Sometimes if the photon hasn’t ever been paired it works fine, other times not.

This is something Particle NEEDS to fix. Nothing like getting your brand new device from particle and their own apps cant even see it, Great first impression to make.

Bright Side: Once you get them to connect they are awesome little devices.

For now, download the CLI and learn to user particle serial wifi setup, silly yes I know but its the only option at this point.

I agree completely, it’s extremely frustrating to get a brand new device and not be able to blink a LED right away. I also downloaded the CLI and tried on Windows but gave up after more than an hour of trying and still having issues with the driver. I was also kind of surprised that given the open nature of particle, their Linux support is not great. I agree though that the mobile app needs to be fixed. I was about to go back to Electric Imp if I couldn’t get it to work but am glad I didn’t. Once the device works, it’s very nice.

What issues are you having?

Have you tried the Windows CLI Installer?