Galaxy 6 "No Photon devices found"

My Galaxy does not find my Photon. The Photon is setup, online. Other phones find it. Once they find it and get it online I can flash programs to it and it works. That was at a 2.5 day workshop. Mine could not find it at the workshop nor at home. I sure want to get it connected to my router. Thanks for any help!

Could it be that the Galaxy 6 is using 5GHz band only?
The Photon only supports 2.4GHz.

Crosslink to “double post”

Thanks. If that is the problem, is there anything I can do about it? Note that I tried using an iPhone too without success.

Most recent iPhones are also known to prefere the 5GHz band.
If it is in fact that, then you’d need to find a way to restrict you device to only use 2.4GHz for that task.

Thank you. I’m about to go out. I will investigate how to do that later today!

My router shows: Wi-Fi 2.4 GHz, Home…
So it is 2.4 GHz
Back to square one.

I have a 7 Edge and setting up a Photon is tricky.
I have to bounce back and forth between the Photon’s AP and my router’s AP during certain points in the process.
Once it’s setup I sometimes have to shut down my applications and restart the Particle app for it to be recognized.
Sometimes I have to place the Photon into listen mode and “re-discover” the device that way.
Then I shut down the app and restart it.

Thanks. I have been putting it into listening mode, trying it on two different Windows computers. I’ve tried it with an Android phone and two different iPhones. Tomorrow I hope to try it with a different router, but I did already try it with a different router - no luck with my Android but the workshop instructors got it connected with their phones.

So, it seems to me the problem is with my phone, but I am going in circles. I also tried setting up via USB on two different computers. One came close. The terminal emulator message:
Derp. Sorry, we couldn’t save the credentials.

Note that it is in listening mode - flashing blue.
Thanks, Earl

Have you tried it with CLI particle serial wifi (with no auto-scan, all manual) or via the serial terminal and sending w?

Thanks for your continued efforts! I tried both CLI particle serial wifi and particle wifi. I’m not sure if it was no auto-scan, alll manual or not. Also not sure what “sending w” is. All I know is I can not get it online with cell phones or USB. My only progress was finding a terminal emulater, namely Termite, that would let me input my SSID and Password - or at least it seemed to accept it, just would not connect.

When you said Termite, I guess you must have put the device in Listening Mode, connected Termite and then pressed w to get the Photon to ask you for SSID, encryption scheme and password.
What enc are you using?
If it’s WEP there is some extra quirk you’d need to be aware - but I’d recommend moving to WPA2-PSK anyway.

And just for being in the safe side, make sure to clear the credentials before any retry.
Also try some alternative USB cables and ports (best USB 2.0 if you have).

And if nothing helps, you could even flash some code to the device via USB that uses WiFi.setCredentials() to store the credentials from within the device.