Trouble connecting a new Photon

Recieved my first Photon today, dowloaded the android app, powered the photon up and got the blinkiong blue light, all good so far.
Signed in to the app, tried to add a device and “No Photon Devices Found”.
My phone can see the photon wifi network and I’ve tried to add it with and without connecting to the network first but nothing happening.
Am I missing something?
I’ve seen other posts suggesting the CLI to get started but I’m running Ubuntu and can’t find any reference to a Linux CLI.
Any suggestions?

Many thanks

Are you sure?

Thanks, should have looked harder. Would still prefer to get it working via the app if possible

What Android device and version are you using?
Some just don’t play well with the Photon’s WiFi.

Thanks, I’m using a Nexus 5x

Just tried it on a Samsung Galaxy S6, same deal, phone can see the Photon wifi but the app can’t see any devices.

Looking elsewhere, it seems that the android app is broken Marshmallow.


and that makes sense.
Particle has recently hired an Android dev to resuscitate the stalled app development (bug fixing) for that OS.