Cannot claim core

I got my core id by connecting over usb and pressing i. It’s 24 characters. I put it in the claim core dialog, but all I get is “Could not claim core”. :frowning:

I opened up the developer panel and saw:
POST 404 (Not Found)

What’s up, and how do I fix this?

Ahhh! More developer diving and I found the response was:


It would have been nice for you to put this on the web page :stuck_out_tongue:

But now, what do I do here? I know that I previously registered my core, but I think it was under the same account. It’s now just disappeared though.

So: Looking to see if I have another account. Tried logging out of, but every time I go back, it remembers I’m logged in. Is there a way to log out that I’m missing?

I then opened an incognito window in chrome, tried to reset my password. Got an email quickly, but then when I tried to actually put in the new password, it didn’t work. It’s getting a 500 internal server error. How do I reset my password?

Hi @theicfire - if you private message me the core ID, we can check what happened to it

Ah! Remembered my password.


Same problem for me.
My spark core did work well on 2 différents networks for 2 ou 3 weeks.
But now

  1. It connects to cloud as the leds say with normal steps.
  2. My android spark application doesn’t see it (tested on S3, s4, nexus 7 on 2 networks)
  3. I Cannot claim core. I’ve got my Device ID with usb connection.
  4. Last time I saw my spark alive in android application, its name had changed !!
  5. I did factory reset, reset, forget networks, reinstall android application, aso …

Can somebody help me and mostly explain what happened.
I’m french and apologize for my poor English.

I’ve got the same problem I can’t “claim the core”. I leave you my device id :
I can’t connect my android app either although it seems to be connected to the cloud (cyan breath)

May be you can clean this issue as you suggested it to @theicfire ?
Christophe Hugot

Also, to help you further debug more, try opening the developer console in chrome and going to the “networks tab”. Then enter your device id. If one of the entries is red, click on that and then the “response” tab. See if there’s anything interesting there that can help you understand what’s not working.

I also think it’s a bad idea to put your device id on the forum – others could technically claim it.

Thank for your answer. You are right about privacy of the ID, don’t know why I thought it was a private answer !

I found something like that, which (for me) is not very explicit

POST 404 (Not Found)

It worked correctly for 2 weeks and then the id of the core (as seen in appli android) changed to something else. It looks like it exchanges id with another device or ?
Then i can’t do anything althought it seems to be connected to cloud.


Hi @zugy,

Once you’ve claimed your core it’s yours until you release it on the build site. A common error we see is because of how easy it is to create new accounts. Users often login to the mobile app with a wrong email address, and their core disappears because they’re on a different account.

If you email us at with your core ID, and the email you’re using as your username, we can help you figure out if there was a typo when claiming that core.


You are right. It was the wrong account. Thank for your help. Still an issue : my core (good id, good account) had his name changed without me. Its name was spark0 and is now turkey_badger. I wonder why ?

Thanks a lot anyway.

Hi @zugy,

Turkey Badger sounds like an auto-generated name by the spark mobile app. If it thought you were in a new account, and it was a new core, there might be a bug where it figured your core needed a name. :smile:


Thank you one more time.
Now i can go on. But tomorrow, it’s time to go to bed in Paris.

Goodnight in the city of light!