Bricked Particle Photon


I’m having issues with my Particle Photon. When I power it up, the main LED does not light, only the D7 LED dimly lights. Also, the P0 is gets hot to touch.

I’ve tried all the reset techniques based on the forums, but haven’t succeeded.

It’s the same as the issue this person posted: Dead Spark, blue d7 led only, factory reset doesn’t work

I was wasn’t doing anything new, I’d just sent a command to the unit when it stopped responding and the Blue LED D7 was lit and since then, nothing.


@kmmonk maybe something for you since hot to the touch doesnt sound right?

I used an IR thermometer, it creeps up to about 42dC.

No!! 42°C temperature!!


The board was linked to an adafruit servo board. I was calibrating 1 standard hobby servo. I didn’t want to demand too much power, so I had 0 load on the servo and only 1 servo.

I’d also hacked the servo to get a link out from the VR inside the servo, so I could determine the angle of the servo, or if it’d had jammed. This was linked to analog A0, the output range was 0.5 to 2.8v.

I was testing the second servo, sending various position requests when the serial stopped, and the command is sent failed. I looked at the board it was showing the D7 LED lit and the heartbeat had gone.

I’ve trawled the forums for a fix, I’ve tried every kind of reset known to man, tried different source of power via the USB (not tried 3.3v direct), I always get this darn blue LED, no boot and the chip slowly gets warmer and warmer, which I’m not sure is normal or not?

It was probably the 3rd command I’d sent when it happened.

Any suggestions?

Actually I would not get too worried when the chip gets up to 42°C slowly (as long it does not go a lot higher).

The other thing is annoying, tho’ :grimacing:

Could you please give some more details of what happens, when you do the resets?
Does the RGB LED do anything while you are performing the reset?
On the Photon it should first go short magenta, then yellow, then white, when you perform a factory reset.
But AFAIK the factory reset only wipes the user code, so if you should have a damaged system for some reason, you might have more luck with going into DFU mode (yellow blinking) and try to reflash the system.

But @mdma might have some better tips for you.

Thanks for your reply.

No matter which type of reset I try, the status LED doesn’t change. Only the D7 LED remains on.

Is it worth powering via pin, rather than USB?

That doesn’t sound too good, but powering via Vin can’t harm.
And if you have a relyable 3.3V supply you could also try the 3V3 pin.

If this doesn’t work, you may have to wait for the next workday to get a reply from :spark: @Particle.
Meanwhile you could shoot them a mail to

Are you able to get the device into DFU mode?

If not, do you have access to a JTAG programmer?

No to DFU. No to JTag.

Tried external pin power, same behavior. No response.

Photos attached (with USB). I’ve wired it the original way for you to look at.

Ok, so I just realised something. I was feeding into A0 2.5v to 4.5v, the max is supposed to be 3.3v. Forgot to check the voltage from the servo dammit.

Could that have done it? Is it dead?

Although, having said that. The first servo I tested was outputting the same, and that wasn’t an issue.

@flatsheep, 4.5v is a bit high for the analog input. It may have damaged the processor.

Have you tried it with all IO pins disconnected, just usb power?
Does VIN measure 5v, and the 3v3 read right then?
Will it flash that way?

What do you think will be the result of sending 4.5v into an analog input ?

I’ve tried it disconnected (other than USB), no response.

The voltages are: Vin = 4.7v and 3v3 = 3.3v.

Still not responding. I’ve ordered two more boards. My knowledge is in software, not hardware, so this is a valuable lesson learnt! Just hope the replacement boards don’t take too long.

1 Like