LED Won't Blink on Particle Photon Because I Maybe Broke It

So I’m working on a project for an IoT class and had my Particle Photon connected to a bread board, servo and buzzer. I flashed the code to the Photon, it worked, and the motor started turning.

Buuuuuuut because of poor planning on my end, the device the motor is attached to started spinning out of control and knocking things off my counter, so I panicked and unplugged the Photon while it was in mid-cycle. And now the none of the LED lights will come on. I tried resetting it, but nothing happens. Did I short the device?

I am by no means technologically savvy, so I’m not sure if there’s anything else I can try?


Does it respond to CLI commands when attached to your computer via USB? Try putting it into serial or DFU mode and running particle serial identify and / or particle device doctor

It’s possible something shorten and got bricked. When you say you unplugged it, did you remove the photon from the breadboard, remove the usb, how did you do so? Also right now is it still on a breadboard or have you isolated it?

I removed the USB cord. I’m also unable to get it respond to CLI commands.

Depending on how hard you yanked it, it’s possible there was damage to the USB connector. Can you try powering via a breadboard and 5V power source to isolate whether that may be the issue? If so it may be possible to fix / resolder but could be challenging.

You were right; I was able to power it via the VIN pin. Yeah, I’m not great at soldering in general, so I can’t imagine soldering something so small would bode well for me.

I really appreciate your help! I’ll be more gentle with the next one.