Dead particle photon? No LED

After an attempted reset today using the RESET push button, my Photon has become totally non-responsive. Using USB power, I measure 5V at the VIN pin, 3.3V at the 3V3 pin (regulator still functioning), and 3.3V at the RST pin (as expected). No main LED, no light on D7 (~0.25 V), no USB serial connection. No response to either the RESET or SETUP button in any combination.

My first thought was that an iffy power cable connection may have caused a low voltage condition, detailed elsewhere. I attempted to repair the bootloader using the Embedded SWD tool (, but I get either no device detected or SWD protocol error (even after double checking the wiring). Also, when I connected the D7 wire from one device to the other, the D7 LED on the first device went dark.

Any other thoughts of parts of the device to check over, or ideas on what may have died? I don’t want to believe it was ESD, but it’s always a possibility. Maybe something else was shorted before the reset and I didn’t notice?

Could the metal P0 cover be dinted?
That would keep the controller in safety reset to prevent shorting internal components.

Also just for laughters, the device does not enter any sleep mode immediately on power up? (had such cases before ;-))
Can you try DFU Mode?


Thanks for the suggestions, but no luck.

No dents as far as I can see - I can see clear under the top metal casing.

Definitely no DFU mode.

I tried pulling the wakeup pin high/low, no response. There was no sleep mode in anything I put on it.

@blue_dolphin, is the Photon on a breadboard or PCB?

Previously it was connected by cable to other devices (LCD, LED, buzzer, etc). Currently it’s on a breadboard.

@blue_dolphin, try taking out of the breadboard, placing it on a non-conductive surface and power it with USB.

Thanks. No change when taking it out of the breadboard and placing it on a non-conductive table.

@blue_dolphin, I have not seen this type of failure. Normally we see the onboard switcher fail. If you have a scope, it would be interesting to look at the quality of the 3.3v supply. With RESET being high and the lid being fine, I suspect you have a dead STM32.

3.3V power supply on the scope shows maybe 50usec power-on time with a smooth rise, then steady at 3.3V without major fluctuations.

I found a power supply where I could look at current draw and it shows 13 mA. Looks like too little to be running the microcontroller even without wifi powering up. I agree it sounds like a dead microcontroller. Thanks for helping debug, looks like I’ll order a replacement.

1 Like

I’m facing something similar. Photon mounted on perfboard with a 74ahct125 level shifter, and placed inside of a plastic enclosure. Powered by a Mean Well 5V PS. Was working fine one night. Next day it was totally unresponsive - no LED, and when plugged into USB it gets slightly warm (not hot). When I replaced it with a new Photon, it worked fine.

4.8V at VIN, nothing at 3V3 or RST.

I don’t have any kind of more advanced equipment (other than a multimeter) to troubleshoot. Any other tips, or does Particle want to take a look at it to see if you can figure out cause of death?

@rac_atx, schematics and part numbers and/or web links for the Mean Well supply, etc. would be good.

Ah, great point. It is this one:

12A, 60W.

@rac_atx, pictures or schematic or both would be nice.