Breathing Cyan "Core not found. Check that it is online" when using Build

For what its worth, on another Core I’m able to reflash Tinker without issue. Also, the Core that is stuck breathing was operational earlier. It was only after trying to flash the “multiple LEDs” example that it started misbehaving.

Coincidentally, the spark.io website wasn’t fully working around the same time. I’d sent the link to http://spark.io to a friend and he said it was down. When I checked the site, only the first background image loaded. Related?

I was having the same problem as Chris with the IDE saying

“This request is taking longer than usual, please be patient”

and reflashing Tinker with the iOS app gave me

An error was reported by the Spark Cloud. Please try again later. If the issue is not resolved, please visit www.spark.io/support for help.

Holding the mode button down didn’t do anything. I messed around with it for hours and now it’s working. I’m unsure what exactly I did to fix it, but I did hold in the mode button for 10 seconds while powering up and this restarted everything and I entered my wi-fi details with the app and it started working correctly. BUT, I tried this 10 sec on power up thing probably a half dozen times before I got to where I am now.

I have a feeling there was something corrupted that eventually got rewritten with the correct value and now it works. I’ll gladly provide more details if they can stop this issue from appearing for other users.

Hey guys - I think what’s happening here is that the user application that you previously installed is blocking the firmware updates from coming through. @buffington and @Dillon1337, had you programmed the Core with an application that had some long delay() in the loop?

This is something we need to fix, but in the meantime, try to keep the total length of delays in the loop to no longer than a couple of seconds.

Hi Zach,

I think you are right about delay(). I was working on a 500ms LED blinker (similar to the Arduino sample) when the Core stopped being flashable.

Saying that, I followed instructions from David to factory reset the core and now I can use Tinker as normal.

Thanks for your help!

1 Like

@zach I started seeing the problem after trying to flash the “control LEDs over the net” example. That said, there’s a chance I might have tried flashing something prior to that with a long delay. I see if I can reset the core a bit later and recreate the issue.

thanks @buffington, keep us posted!

I thought I would provide my feedback and say that I had this same error in the subject description. Factory reset, then re-sync with android app and problem solved.

1 Like

One more bit of reflection: Out of habit, my LED flashing code contained a while(true) loop within ‘loop()’, which looking back seems like madness! Removed it and now my delay(1000); statements do not stop flashing new code anymore.

Hey guys, just created a new thread for this issue:

Great, thanks for the continued communication on the issue.

So I have the same issue - Error: Core not found while it’s “breathing cyan”

I tried holding down mode and taping reset - no luck… It went through the white cycle and turned amber.
I then tried powering off and on, and this time it booted up in listening mode, and I attempted to connect to it again, but still I have the same issue - Error: Core not found. The last piece of code I flashed had delay(2000) for the humidity sensor that I was attempting to use.

What is the best way to reset it?

@kidrock The two things to try out at this moment would be:

  1. Factory reset the core, connect to WiFi and then Reflash Tinker using the iPhone app
  2. Connect the core over USB: http://docs.spark.io/#/connect/troubleshooting-step-1-set-up-your-core-over-usb

This might not apply, but make sure you click ‘Verify’ before flashing your code. I think we have a bug right now where compile errors won’t show up during a flash that will show up during a verify.

Code verifies fine, I reset it, re-flashed tinker and now and up and running again!

But I am unable to get the Spark Simple Web Interface working (Error: roh roh), dunno if it’s related to the cloud connectivity.

Hi all, I’m getting this same issue.

  • I have only one core
  • I can see the core’s ID on the Cores tab
  • Core breathing cyan
  • Tinker app working - I can switch D7 led on/off
  • I can re-flash Tinker (although it takes a couple of mins of magenta flashes - is that normal?)
  • This is my very first attempt to flash firmware
  • Verifies with no errors
  • Flashing gives message “Error: Core not found. Please check that it is online.”

Not relevant, but here’s my code anyway:

void setup(){
    Serial.begin(9600);
    pinMode(7, OUTPUT);
}

void loop(){
    digitalWrite(7, HIGH);
    Serial.println("Hello");
    digitalWrite(7, LOW);
    delay(250);
}

Thanks for any assistance.

Paul

Well, I have now sucesfully flashed my core, several times. And I seem to have figured out why it did not work before. I don’t understand why, but it seemsto be consistent: I can flash using Firefox (26.0). I can’t flash with Opera (12.16). Everything else seems to work ok in Opera - saving, verifying, viewing core ID & access token, but flashing gives the “core not found” message every time.

Opera also gives me some problems when composing messages in this forum. The Preformatted text function doesn’t work properly, for example.

Its a shame, I like Opera. Its faster than Firefox, and has built-in email and html editor.

Paul

Thanks @PaulRB for reporting that; we’ll add that to our back-log to fix.

The reason for this is that the web IDE hits the API at https://api.spark.io, and since this is a different domain than the build site, it’s a cross-domain request, which different browsers handle differently. We hadn’t tested it on Opera, so I’m not entirely surprised that it wasn’t working correctly.

Hi @zach, unfortunately my success today was short lived! I now have the “other” problem. My core carries non breathing cyan and does not respond to firmware updates. Have tried factory reset twice (i.e. hold mode, click reset, continue holding mode until white flashing starts) and numerous simple resets and power cycles.

The whole wifi credentials part of factory reset is working as far as I can tell, except that I never get the shouting rainbow. It returns to breathing cyan.

After factory reset, the core seems to be flashed back to Tinker (magenta flashing for ~ 1 minute). Afterwards, I can control D7 led via tinker app again.

I am still using Firefox and the IDE is reporting “Flash successful! Please wait a moment while your Core is updated…” but the cyan breathing continues.

Paul

If you hit ‘Verify’, does your code successfully compile that way? We have a separate bug currently where sometimes ‘Flash’ says it was successful even when it actually wasn’t…

@zach, you’re absolutely right.

I had made this error in my code:

  Spark.variable("temp", &t, int);
Spark.variable("humid", &h, int);

instead of:

  Spark.variable("temp", &t, INT);
Spark.variable("humid", &h, INT);

Verify gives this message:

../95282f660199db135e987c6f4cc96679f0442b3b3226c0a7ac04f07d7cf4/the_user_app.cpp: In function 'void setup()':
../95282f660199db135e987c6f4cc96679f0442b3b3226c0a7ac04f07d7cf4/the_user_app.cpp:206:30: error: expected primary-expression before 'int'
../95282f660199db135e987c6f4cc96679f0442b3b3226c0a7ac04f07d7cf4/the_user_app.cpp:207:31: error: expected primary-expression before 'int'
make: *** [../95282f660199db135e987c6f4cc96679f0442b3b3226c0a7ac04f07d7cf4/the_user_app.o] Error 1

Error: Could not compile. Please review your code.

But presing Flash gives the message:

Flash successful! Please wait a moment while your Core is updated...

So its the same bug you mentioned.

Thanks!

1 Like