[Solved]: Unable to Flash Spark Core Error: "Request Timed Out"

Good Day,

I am currently having some troubles flashing to the Spark Core from the Spark Web IDE. I flash the code and it goes for about a minute saying:

Flashing code...if it does not flash magenta, verify your code and try again.

Then it comes up with:

Request Timed Out    
Flash unsuccessful.

I have tried setting my Spark Core back to blue (Listening For WI-FI Credentials) and reconnecting it my account… Multiple Times. I still didn’t work. The same thing recently happened to me where it was coming up with the Request Time Out error, and it turned out to be my code. So I tried one of the Spark Example programs (Blink An LED) and it came up with the same error.

It is coming up with all these errors even though by Spark Core is breathing Cyan.

Thank you in advance,

1.) Is there a *breathing cyan indicator for that device under the Cores tab for Web IDE?

2.) Try a factory reset so that the core is running tinker and test again :wink:

  1. Th

The indicator is on the Spark Core, not on the Cores Tab

I have tried that already twice

Thank you,

Go to: https://build.spark.io/build#cores

You will see a breathing cyan icon beside the device if it is online.

Are you using spark-cli? You can also use the command spark list to see if the core you are trying to reach is online.

Do you mean to go to the Cores Icon on the bottom left corner of the Web IDEÉ

No. I am not, I am using the Spark Web IDE.

Yup that’s right

I don’t have any devices online to screenshot the breathing cyan light but you should be seeing it on the right of the device name

Yes, I used to have that light beside my the of my Spark earlier. But now there’s nothing at all.

Was anything changed? Maybe you can email hello[at]spark.io with your account user name as well as the core id to see if there’s anything weird with the cloud service.

Thank you for the suggestion. I am waiting on a reply :smile:

I haven’t gotten a reply yet, but I tried factory resetting my Spark Core… And it worked! Thanks for all your help @kennethlimcp!

1 Like

@kennethlimcp, the same error is coming up again :sob: ! It was connected for a bit then this came up:

Any other suggestions?

@Ricky, i have notified the team about your issue already.

@harrisonhjones might want to look into your ticket and assist you offline


@kennethlimcp & @harrisonhjones, it turned out the code on my Spark Core was causing the Spark to go into infinite loop. I had to factory reset my Spark Core then upload the Blink Program to see if it works. Thanks for all your help! :grin:



@kennethlimcp, I am having the same proble as @Ricky, my core times out without flashing. The core is present in the cli with the command. It is also present in the web IDE with a breathing cyan light. I have tried different code but still no flash. I dont think anything has changed apart from renewing the keys.

I then set up my son’s lap top with spark Dev and tried to flash a USB connected core from there and from the web IDE. It would not flash. :frowning:

Any ideas what I can try next?

Cheers :slight_smile:

Trying doing a factory reset and play around with OTA flashing of an empty app.

The core should work well using the default tinker but if it doesn’t there might be some issues.

@Dave maybe something for you?

1 Like

Hi @kennethlimcp a factory reset seems to have sorted it out. It is now flashing from the web IDE and Spark DEV.

Thanks for you support.



I’ve had a similar problem compiling with Spark Dev. Attempts to compile a program with Spark Dev kept timing out, no other error message. It turned out to be that a library I had added to the program was not in the same folder as the program. I had my Arduino IDE hat on, so placed it under the library folder.

I was not getting an error message that the .h file could not be found. Just a time out on the compile. I’ve had other program errors result in timeout, rather than an error message. Its very tough to debug code when that happens.


Hi @Bendrix,

That’s really strange, I’ll try to find that bug and fix it, it definitely should have given you something more helpful!


Started reply to wrong post.

I have been having the identical problem. However the factory reset failed to go White and many other threads say AVOID factory reset. Any other suggestions?