Cannot Flash Firmware

After having great success yesterday, using the web IDE to flash updates to my Core… I am now unable to complete an update. Thinking it may be a problem in my program, I brought it back down to a basic blink program… still no luck at all.

Starting with a stable cyan breathing for at least several minutes (I wanted to assure myself that the wifi connection wasn’t timing out on its own.)

When I press flash, I get the multi-coloured led flashing, but then a few periods of no light… then blinking cyan (fast) and moves into the cyan heartbeat.

It appears to me that the flash attempt is timing out, or that its wifi connection is timing out during the flash attempt.

Based on many posts here, I tried the so-called ‘factory’ reset several times, and still no progress.

The CC3000 patch/deep update might help. It’s been proven useful before. There are guides on how to apply them in the docs if you’re willing to give that a try.

Thanks for the report. I would try @Moors7 suggestion of an CC3000 update. Additionally, if you plan on doing a lot of work with your core I would suggest investigating a local build environment. It allows you to compile and flash locally (much much faster and more reliable). The added benefit is that you can still flash remotely if you want to later (using the SparkCLI)


Thanks, that sees to have worked, while going through all the machinations for the update isn’t exactly a lot of fun!

I will have to monitor it for a few days.


I appreciate the help! the CLI is a nice tool, although it seems like the Spark Dev tool ought to be able to compile and load locally, even if it must be put the Spark into dfu mode.

1 Like