Boron FW restore


#1

Where can I find the boron 8.x FW binaries tor store to my brand new boron I just bricked?

Thanks,

Jeff


#2

Ditto here. I bricked mine too. I found
https://docs.particle.io/support/troubleshooting/firmware-upgrades/boron/
which says to go to the github release page and download system-part1-x.y.z-boron.bin, etc. But there are are no boron files on that page.


#3

You can try to factory reset the device

  • power-up device
  • press/hold MODE 10+sec till rapid blue flashing
  • relese MODE
  • press/hold MODE
  • tap RESET
  • wait for magenta -> yellow -> white - > rapid white flashing
  • release MODE
  • “add” (althought it’s already there) device to your account via mobile app

Boron stuck in DFU mode
#4

Thanks for the suggestion. Even through https://docs.particle.io/tutorials/device-os/led/boron/ says “Factory reset is not available on the Boron” I tried it anyway. Got the rapid flashing white light, but it doesn’t help - I still can’t add the device.

That page actually says “Factory reset is not available on the Boron, but not to worry! If you are experiencing problems with your application firmware, you can use Safe Mode to recover.” However, “If you’re unable to connect to the cloud, you won’t be able to enter safe mode.” I’m not able to connect the cloud and cannot enter safe mode.


#5

@jeffmc, when you say bricked, can you describe what is happening?

Is it blinking green continuously, or?


#6

medium blinking blue light. I had tried to load FW on it, and it just sits there with a medium flashing blue light. I did the procedure ScruffR suggested, but it asked me in the app to do yet another subscription. I just want to put the original FW back on. I tired building the FW from source, but apparently, the bit to load the ARM tools (the ruby script) has an error.

Explain to me why I just can’t get the FW binaries and flash the device? Or should I pack this all up and ask for a refund?


#7

White light rapidly flashes, then goes back to medium speed blue blinking LED (listening mode, I believe). I am pretty conversant in the U-Blox SARA-R410, and I have a mother device from another company sitting here just fine connected to the cell system.


#8

There (currently) there is no one-click factory reset, but the process discribed above should put the device back into a state where teh mobile app should be trying to re-apply the “default” firmware.
After you scan the data matrix of your Boron, the most recent device OS should be applied.

Unfortunately I can’t try it with a Boron due to lack of one :pensive:

Because Particle is just in the middle of the process to wrap up the rc.25 binaries but due to weekend people are not at the office and rc.24 are not advisable anymore.

I think that’s unnecessarily facetious.


#9

Um, If I was their CEO, I would be making their team work the weekend.


#10

Hmm, you obviously haven’t seen what lengths the team has been going through and how much overtime they happily worked to get to where we already are and what tremendous work they have done so far.

Sorry, but hearing that, I’m glad Particle CEO is more understanding.


#11

He is understanding by not putting up binaries to support his customers?


#12

Before this turns to a “I think the CEO should/shouldn’t”, let it be known that the entire team has been working incredibly hard at this for a long, long time. To get to this point, a lot of work has been put into this by all members of the team. Mesh is a new territory, and getting the hardware into the hands of developers was the first, arguably most important, step.
Software has been worked on in parallel and improvements are continuously ongoing. They’re being released when deemed ready, as fast as possible.

That said, there’s more to life than work, and those working on this deserve to live a life as well. Programmers are people too. They too have families that would like to spend time with them occasionally.
Binaries can’t be put up when they’re not finished, nor can they be finished if those working on them have their, well deserved, time off.
With that in mind, tomorrow’s Monday, who knows what that’ll bring when those engineers have been well-rested and re-motivated after spending their free time doing things they enjoy.


Boron LTE Firmware
#13

Patience is a virtue in short supply, but Particle is doing its best to deliver still
Even before the official announcement: The new binaries are out and this week has only started.


#14

Despite the title, this page (which I believe is quite new right now) has links to the latest Boron firmware. (I haven’t tried it myself)

https://docs.particle.io/support/particle-devices-faq/electron-3rdparty-sims/#setting-up-a-boron-with-a-3rd-party-sim-card


#15

I am also trying to restore my Boron after loading a custom firmware (to test BLE central example from nrf example code, which worked fine). But I am unable to reload the particle firmware back on.

I am using the J-Flash Lite programming software and loading the Boron bootloader and hybrid .bin files to their corresponding locations (based on the memory map). But the board is still not working. Any suggestions for resurrecting it.

Thanks.


#16

Can you be a bit more specific what exactly is not working.
What does the device do when powered up?
Can you enter any of the known modes (DFU Mode, Listening Mode, Safe Mode, …)?
Can you try loading the Boron Monolithic Tinker?


#17

The board is completely dead (can’t go into any of the modes).
But I can run my custom firmware (which blinks the LED. So I know that uC is working.

I tried loading the monolithic image but still same issue. After programming, I tried to go into boot-loader and DFU by holding the reset and mode buttons, but the LED does not blink. I am assuming the monolithic image starts at 0x0 flash address.

Probably, I am missing something very simple.


#18

Flashing any code to flash location 0 will overwrite the nRF52840 soft device, which will render the device inoperative. The only way to recover from this is SWD/JTAG:

https://docs.particle.io/support/particle-tools-faq/jtag/#programming-the-boot-loader-3rd-generation-

The bootloader gets flashed to 0xf4000.
System firmware or a monolithic app gets flashed to 0x30000.


#19

Still no luck.
I loaded the software device hex to the address 0
and monolithic app to 0x30000 and boot loader to 0xf4000

What if the APP_CODE_BASE value in the software device image is not 0x30000?


#20

I also got SOS signal and unable to back to factory reset.

Maybe because of below code.

FuelGauge fuel;

Particle.publish(“phototransistor_1,battery”, String::format("%d,%s", analogvalue, fuel.getSoC()), 60, PRIVATE);

I did reset until I got medium blue blink LED (listening mode)
Then I using mobile apps to add again but it’s not updating default firmware.