Boron not connecting after 1.4.0 update

Today I compiled a known working project (1.2.1) on 1.4.0. After the Boron updated and uploading the new firmware over dfu the led on the Boron flickers white. After removing power 100% and reapplying power the device will try to connect and stays flashing green. When I put it in safe mode the device will reach Particle, flash red once, and then try to reconnect all over again. After about 20 attempts the led turns back to flickering and the boron appears dead. Reflashing tinker in dfu mode does allow the device to reconnect to Particle successfully.

Any thoughts on what might be going on? This firmware hasn’t changed in months now.

Did you update the bootloader?

As far as I can tell the bootloader uploaded automatically from Particle.

Checking via particle serial inspect won’t hurt.
You may also want to update the SoftDevice just for safety.

Serial times out in normal mode and safe mode. I tried updating using the particle update command. It said firmware needed updating. After it completed the Boron entered into the same cycle.

I want to blame my code since that is usually the issue, but how can my code affect safe mode?

Does this also happen in Listening Mode and Safe Listening Mode?

Yes. So far I get the same results on 3 different borons. 2 that updated from 1.2.1 to 1.4.0 and 1 that updated to 1.4.0 straight out of the box before installing firmware.

I am still not sure how it prevented the device from connecting in safe mode. But in my code this line caused the issue

	SPI.begin(SPI_MODE_MASTER, -1);

Where -1 was supposed to be a pin.

1 Like