Solved - Boron won't flash, but has partial communication

Update: I’ve been able to get the Boron into safe mode, and now it will update. It took a so…many…tries to get it to go into safe mode, and then to successfully reconnect to the cellular network, but eventually it worked.

I’ve been tinkering with a new Boron yesterday and today. it won’t flash from the Web IDE any more. The Web IDE reports that the flash is successful, but the Boron doesn’t change behavior: It just remains in the breathing-cyan status light mode, and doesn’t give any indication that the new program has loaded.

If I hit the reset switch, it goes through the reconnect sequence. The reset appears in my Particle Console. So SOME communication is happening.

If I select a different particle device that isn’t actually plugged in, the Web IDE does realize that it’s failing to flash that device. If I then swap back to this Boron, it goes back to claiming the flash is successful.

If I hit the “signal” button in the Devices menu for this Boron, the web IDE indicates that the boron is signalling, but the Boron does not change behavior. (No LED signal, etc.)

Things that have happened recently:

  • Yesterday I tried using Visual Studio Code to do local builds/pushes. I didn’t get that working. (Have I successfully flashed since then? Not sure.)
  • Today I threw the Boron (in a solderless breadboard) into my satchel and coded on it at the gym. I didn’t have it plugged into any peripherals that made output, so I’m not sure if any of those pushes earlier in the day actually took. Maybe it got jostled badly in the bag? There’s no obvious damage and the cell antenna is still seemly well attached to the u.fl connector.
1 Like

Good to know you found a solution :+1:

I just reposted your solution to be able to mark the thread as solved.

1 Like