Boron no longer connects after firmware update

I am working on a Boron that originally had V1.1.0 firmware. It had LTE connectivity and worked fine. I decide to do a firmware update since this version was old.

I tried to update it with OTA but it failed. Instead I used the CLI. I put it in DFU, used the v2.2.0 CLI and issued the “particle update” command. It was successful but now it no longer connects to the particle cloud. It just blinks dark blue.

Any ideas?

I figured it out. I did the following:

In the CLI:

  1. Put in DFU mode.
  2. Do “particle update”
  3. Put in DFU mode.
  4. Do “particle flash --usb tinker”
  5. Reset
  • At this point is should be flashing dark blue (listening mode)

To get it out of listening mode the setup flag needs set:

  1. Upload the following program and run:
#include "Particle.h"

#include "dct.h"

SYSTEM_MODE(SEMI_AUTOMATIC);

void setup() {
    // This set the setup done flag on brand new devices so it won't stay in listening mode
    const uint8_t val = 0x01;
    dct_write_app_data(&val, DCT_SETUP_DONE_OFFSET, 1);

    // This is just so you know the operation is complete
    pinMode(D7, OUTPUT);
    digitalWrite(D7, HIGH);

    Particle.connect();
}

void loop() {
}