Boron constantly in Listening Mode


#1

Just spinning up my first Boron. Managed to flash it with new firmware, but the thing just sits in listening mode, rather than switching to green and trying to connect. What could be causing this issue? Is it possible that I’ve given it the wrong type of SIM card (I’ve tried it with a Soracom SIM and a SIM from a 3G Electron)? IS there something else? When I try to connect to the Boron via the app, I just get an endless attempt to pair (without ever actually connecting).


#2

Some additional - possibly relevant - information here. I cannot connect to the Boron via the phone app, and when connected via USB the Boron does not show up on my ports list via device manager. Instead it shows as Boron CDC mode (with no driver).


#3

What kind of Boron device do you have?

Boron LTE or Boron 2G/3G?

Either way, if you are using a 3rd party SIM you’ll have to follow instructions for doing so, here:


#4

Thanks for the quick reply!

It is a Boron LTE. I’ve stopped using the 3rd party SIM and am jsut trying to get it up and running using the embedded SIM or one of the Particle SIMs I have.


#5

I actually have a whole bunch of these kits, so I pulled out a brand new one to try again with a totally virgin setup. flashed it with hybrid-0.8.0-rc.25-boron.bin. Flashes just fine, I can reset it into listening mode and…nothing. Can’t pair with my phone can’t run particle identify.

The diagnostic LED is blinking blue, the orange CHG led blinks a few times once every minute and the D7 indicator is solid blue.

My computer (Windows 8.1) doesn’t seem to recognize the device outside of DFU mode either. This is what I get in listen mode:


#6

Is the Boron in a breadboard or still in the black foam it shipped in? If it is in the foam, move it to a breadboard.

And for the CDC device, I had to install the serial drivers using zadig even though I installed the latest CLI using the windows installer. I don’t have the link for those instructions at the moment but you can search for zadig on here.


#7

Boron is in a breadboard (just by chance - didn’t occur to me that the styrofoam might cause an issue).

I ran Zadig for the CDC mode, and it basically moved the problem. Now instead of missing the driver, I get a “device not attached” error. Still no BT or Serial connection. :frowning:


#8

For serial mode, change the driver to “USB serial” driver using zadig. For DFU mode use libusbk driver. I don’t know why I had to load these manually… I’ll wait till the software matures a bit to make conclusions.

Good. The shipping foam is conductive to dissipate ESD.


#9

Thanks! That was quite a journey!

I have now successfully run Identify.

Still have to figure out how to connect it with the app, or the console via cell, or flash my own code. one step at a time.


#10

A new driver package that will serve the new platforms too is currently undergoing testing against different Windows setups - so it’s worked on.


#11

aaaand got it. Solution was to borrow a friend’s iphone. Add another Android to the non-functional list. HTC running Android 7.0


#12

Same problem for me …boron 2G/3Gin listening mode with a fresh install of android application on an ASUS phone …

how resolve the problem i have no iphone to test … :-/


#13

Which HTC device were you using?


#14

HTC M8, I believe


#15

Upside is, once I solved the phone thing, everything went swimmingly.


#16

Please have you an idea of when you will patching the android app ?


#17

It’s always good to state what version of the app you are currently using.


#18

For sure : version 2.3.7 the lastest :slight_smile:


#19

The latest Android app, 2.3.8, is out now. Update the app, and then update your Boron to the new rc26 firmware via USB, and it should all work as expected.

Let us know how it goes! :slight_smile:


#20

Hi,
i just update ma Boron firmware and android APP, i’m still blocked during “Connecting to the internet via Cellular” and my boron is bliking green (with a short white blink each 8/10 secondes).