Boron blinking yellow, not communicating or working

Hello. Boron stopped working for some reason a week ago. Tried a lot of things to “revive” it… Not successful yet.

Problem: When I give it power, it instantly starts blinking the LED with yellow light. There is no connection to it through “”, it says that the device is not powered on.

What was tried:
Entering safe mode, firmware reset, Factory reset, using other PC to flash a code on to it, using my PC to flash a code to it. Every time it keeps replying that the device is not powered on or that there is no reply. When i hold down the mode button and press reset, it changes colors to display “different choices” but still it always go back to blinking the LED yellow.
Tried pairing the device as if it was new, but i get the reply that it is not activated/turned on.
:confounded: maybe someone has any ideas?

Yellow blinking indicates DFU Mode and when you cannot get out of it typically requires a full firmware reflash (device OS, bootloader, SoftDevice and application).
Probable cause for this behaviour may be a failed update.

I’d start with particle update -v.
If that doesn’t help download the individual binaries from the open source repo and flash them one by one via particle flash --usb <firmware.bin> -v.

1 Like

Thank you. This saved it. Donloaded the CLI(which i didn’t know that existed) typed in “particle update -v” and it fired right up.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.