Boron 404X not able to connect to cloud

Hi,
I am based in Ireland, I ordered 3 Boron404xs and all of them are not connecting to cloud.
While trying to setup these borons through app I am stuck at connecting to cloud via cellular.
I have tried the web tool to flash the device but it fails.
It is showing the same DFU flashing failed for all the three devices.

However, I factory reset them and flashed through Particle CLI, now they are with latest firmware as shown below.

image
image

All the three are flashed with firmware version 4.0.2. But when trying to connect to cloud it stops at “connection to cloud via cellular” and throws an error message again.
Can you please help me with this, it has been going on for a month now and new Boron404X is still not working, however the Boron model BRN310 has no problem connecting to cloud even after unclaiming them.

Thanks and Regards
Antony

@antony_RTR the reason why the devices won’t connect is because the BRN404X is a LTE CAT M1 device that will not connect in Ireland.

Using the Cellular Carriers doc on our website it is recommended you use the B524 as shown below.

1 Like

Hi Erik,

Thanks for the update. Is BRN314 or BRN310 available to buy because because it seems like the B524 has different footprint than BRN310 which we have been using for our board.

Thanks
Antony

Hi Antony,

Unfortunately the BRN314 has been deprecated. It may be that we do have some stock, I just don’t know that info. If the website says its in stock, then I would go ahead and order. Cheers!