Boron 404X won't connect to cellular

I’m new to particle and IoT, and trying to get a Boron setup in my account.

Following the guide in the mobile app (android) I was able to get the sim to activate in the console but haven’t been able to claim the device so that it shows up under “My Devices”. During the setup procedure of “Connecting to the Internet via cellular” I get an error that says “Setup has encountered an error and cannot continue”.

The on board led flashes green rapidly telling me it hasn’t connected to a network. I have released the Sim and tried setup several times with the same result. I live in the USA and use AT&T for my mobile phone and do not have any connection issues.

I attempted to follow the resolution in this post ( Boron can't connect to cloud ) but it didn’t seem to make any changes. I also could not get the debug to output any data, so I’m probably not savy enough to use CLI to write firmware hardwired yet. Also seeing how old the post is I wasn’t sure if it would put unusable firmware on my device.

I’m hoping someone has a solution. Thanks to anyone with input!

Hi there, can you please DM @Colleen with your Device ID?

(post deleted by author)

@Colleen must have DMs disabled, any suggestions?

@theflooster I’m a bit confused, you had already messaged me when you said that my DMs didn’t work. Did you get some sort of error message?

@Colleen was incredibly helpful in getting my device working. Thank you again!

What finally ended up getting it to breath cyan was to run the device doctor in docs.

So far so good, flashed several small apps to it over the air and have control through my android app.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.